Mechanics

GMC SIERRA ENGINE PROBLEM

1997 GMC Sierra • 96,000 miles

I have a 97 gmc sierra 1500 4.3L hestitation at idle and sometimes at first acceleration.
i have changed the O2 sensors, plugs wires cap and rotor, coil, checked fuel rail pressure and have done a vacuum test and still nothing. There are no codes and the CEL has never came on.
Any advice would help.
Thanks Dan.
Avatar
Beav1411
November 16, 2012.



What is the fuel pressure spec? Do you have the spider fuel system? That type system is known for problems. Cold start idle issues? Runs ok after warm-up?


JDL
Nov 16, 2012.
Fuel pressure spec that I was given was 56-60 at startup, idle around 55-56psi with a pound or two drop off at engine shutoff.
As fur the spider fuel system I believe I don't.
Air temperature doesn't matter and engine temp doesn't matter, I have had a no start for two days and after I got it towed to the shop the next morning it started and ran the best it has in a while.


Tiny
Beav1411
Nov 16, 2012.
You do have the spider fuel system. 60--66 psi, key on engine off. Psi is less with engine running. I'd check codes anyway, I've had inactive codes point me in the right direction. I need more info to go on.


JDL
Nov 17, 2012.
I have check for codes before and I have none. As for me having the spider fuel system how do you know if that is the problem? What tests do I proform? My fuel pressure at key on engine off is 60-61psi. I have just finished running engine and spray brake cleaner around intake and twice I had a poping sound on the left rear side of the intake but I can't get it to do it again. In the area of the intake and the cap. The rpm did not rise so I don't think vacuum leak. Got any more ideas.


Tiny
Beav1411
Nov 18, 2012.
This info is for hesitation--sag and stumble, no codes.


JDL
Nov 18, 2012.