Mechanics

FORD F-250 GLOW PLUGS PROBLEM

1997 Ford F-250 • 371,000 miles

Its a 1997 powerstroke diesel. It ran fine yesterday. Today it hasn't started and the glow plug/fuel heater fuse blew twice. And I don't know where to start. The plugs going in to the valve covers for the glow plugs are not burnt. I'm starting to wornder if I have a chafed wire in the high voltage bundle. Any help would be appreciated.
Avatar
Dub2012
December 29, 2012.



Disconnect all the glow plugs and replace the fuse. See if it blows, if it does not, then attach one by one till it blows, then you found your issue.

You could also use an ohmeter to check each one by itself.

Roy

ASEMaster6371
Dec 29, 2012.
So one or more glow plugs are gounding out?

Tiny
Dub2012
Dec 29, 2012.
I would start ther. If they all check out, then we need to look at wiring and the controller

Roy

ASEMaster6371
Dec 29, 2012.
Thanks

Tiny
Dub2012
Dec 29, 2012.
I pulled off the drivers side valve cover, cause its easier. I should have known one of the injector harness' plugs melted in to the valve cover gasket.(It happened before on the pass. Side) but I was messing with my multi meter and the glow plugs that I pulled out. How many ohms should there be across the glow plug itself? 2 averaged about 1ohm and the other 2 had no reading.

Tiny
Dub2012
Dec 29, 2012.
The ones with no reading are bad. They all should have some readings.

The valve cover gasket plug is a common failure and a bad design in my opinion. Just miss the 7.3 motor, what a dynamite motor

Roy

ASEMaster6371
Dec 29, 2012.
Always the famous quarter trick for those, except when they melt.
I'll save the good glow plugs. I have a set from diesel rx. Thank you for your help. Im shooting for another 230000 miles out of my truck. Have a great new year.

Tiny
Dub2012
Dec 29, 2012.
You too

Roy

ASEMaster6371
Dec 30, 2012.