Mechanics

A/C AND P0340 PROBLEMS. WHAT COULD BE CAUSING IT?

1997 Ford Aerostar • 255,000 miles

I had a leak through the quick connect on a heater house below the A/c compressor. It took 2 years to find and only after a crack appeared in the temperature control module sprewing rad fluid everywhere. At the same time a seal went on the tranny. Both were repaired along with repairing the flang on the exhaust. Right after repairing the seal on the tranny and the flang on the exhaust I got a check engine light with error codes for the air mass sensor and the P0340. We changed the air mass sensor and the crank shaft sensor. The code for the air mass sensor disappeared but we cannot trace the problem for the P0340 despite changing the crank shaft sensor. Also the A/C keeps coming off and on although the dash switch is set to off and the volt amp light flickers off and on at low idle but goes out when I start driving it. We checked the alternator which shows 14V and the wires for the crank shaft sensor which appear all right. We are somewhat baffled now. What can be causing the A/C to turn off and on despite being shut off on the dash and where do we look next to find the problem with the P0340 code? We have also replaced the coil pack and plugs and wires and done an oil change. Your help would be appreciated. Thanks, Cheryl (Sorry I can't donate but I refuse to use credit cards.)
AD
Avatar
CDhunt
November 2, 2011.



The 340 code is for a cam sensor, not a crank sensor. A code never identifies a bad part, just a failed system.
You need to have the sensor checked as the syncronizer may have failed as well. A shop can verify this.

Also, ford had issues with a 340 code being caused by a bad dpfe sensor. That also needs to be verified by a shop with a scan tool.

Roy



AD