Mechanics

PONTIAC SUNFIRE SENSOR PROBLEM

1996 Pontiac Sunfire • 270,000 miles

2.2L, Manuel, Sunfire, no air cond, fuel injected
One day car started to run rough, sounded like misfiring, weak acceleration at gas peddle around 1500-2000rpms in each gear. Would not go over 3000rpms revving in neutral. (Car has broken muffler) Took to shop, diagnoses said "Running rich code" and "EGR code". I then got exhaust fixed (put straight pipe in took out Cadillac, NO sensor in this model behind cadillac). Changed plugs and wires, car is still sputtering on acceleration but least able to slowly get to highway speed, but not up hills. Car is still running rich and sometimes smells like its carbonated up.
Avatar
Spaceystacey
January 6, 2013.




First, federal law says you must have a catalytic converter on the car. You should have that replaced. As far as the codes. Have you checked the EGR and O2 sensor?

No, have not changed them, the shop said they suspected the Cadillac because of the EGR code. So I did that first, Now Im really trying to narrow it down as good as I can. My money is coming up short. No engine light on at all, what should be the next step?
AD

Tiny
Spaceystacey
Jan 6, 2013.
One guy mentioned something about a temperature sensor for the fuel pump. I got back about a month ago from a winter province only being there 2 months, it got down to -35. Maybe it has not adjusted itself to this climit?

Tiny
Spaceystacey
Jan 6, 2013.
My first concern is without a converter, the sensors aren't going to adjust properly. Does the engine have 270K on it?


AD