Mechanics

96 4.3L CMEFI V6 TESTING FUEL GAUGE

1996 GMC Jimmy • 250,000 miles

Im testing the power going to the fuel meter body I pull the connector off test each set of wires coming from the pcm I get good strobes on all 6 but I thought I was suppose to have constant power when ignition is on. But I dont get a code. Looking for help with finding the ground wire on the intake manifold, proper way of testing power to injectors>>fuel system is new up to the fuel meter body>> this issue came up about 50 miles back, started stalling in idle and when driving making stop or sudden slow down, I only had a cold start issue before this. Check engine light stays solid when you turn it on, no codes came from the scanner. Not sure if im testing the constant power supply to the injectors.
Avatar
Donnie7
May 4, 2012.




Get a noid lite and hook it up to the injector harness-while cranking engine over the noid lite should be flashing, also check the ECM/IGN fuse no.10 20amp in I/P fuse block-

Tiny
Rasmataz
May 4, 2012.
I get good strobing lights on all. And fuse is good
AD

Tiny
Donnie7
May 4, 2012.
Check the fuel pressure with a gauge if its within specs

Tiny
Rasmataz
May 4, 2012.
Test done and it only shows 16psi I don't understand the fuel pump is new and filter is new too.

Tiny
Donnie7
May 5, 2012.
See fuel pressure below-injector/s or the fuel pressure regulator are probably leaking

Tiny
Rasmataz
May 5, 2012.
Ill do that but a question, would it atleast try to start if fuel is leaking inside the plenum?

Tiny
Donnie7
May 5, 2012.
Are you getting spark if so it should be able to fire up -too much fuel will cause it to flood out

Tiny
Rasmataz
May 5, 2012.
I have plenty of spark. But it don't try to start just turns over. And power to injectors

Tiny
Donnie7
May 5, 2012.
Your fuel pressure is way too low-

Have you use the noid lite to test the injector circuit? You need to do this

Tiny
Rasmataz
May 5, 2012.

AD