Mechanics

I HAVE THIS CHEVY 3.4 IT WONT START IT CRANKS BUT WONT START IT JUST SOUNDS LIKE IF IT WANTS TOO TURN ON BUT IT DONT

1995 Chevrolet Lumina • 100,000 miles

* I CHECK THE SPARK PLUGS AND IT HAS SPARK
* I CHECK THE FUEL PRESSURE AND IT HAS 55%
* I CHECKED ALL THE SPARK PLUS TO SEE IF THEY WERE WET AND NO THEY WHERE DRY
* I CHECKED ALL THE FUSES THEY ARE ALL GOOD
* I TRIED SPRAYIN STARTING FLUID BUT WONT START
**[PLEASE HELP ME WHAT DO YOU GUYS THINK THE PROBLOEM CAN BE]
Avatar
John1227
June 25, 2012.




There is only one thing, does it have compression?

3 things needed are fuel, spark and compression.

Roy

ASEMaster6371
Jun 25, 2012.
I HAVENT CHECKED THAT YET. BUT I HAVE CHECKED THE TIMING BELT AND THE BELTS IS OK ITS LIKE NEW.

Tiny
John1227
Jun 26, 2012.
Does not have a timing belt. It has a chain.

Roy
AD

ASEMaster6371
Jun 26, 2012.
IT HAS TO COVERS BETWEEN THE POWER STEERING AND ON THE SIDE OF THE WATER PUMP. IT HAS TWO SCREW SIZE 8, U TAKE OF THE COVER AND THERI LIKE A 1 INCH OR 2 INCH THICK BELT UNDER THOSE COVERS.

Tiny
John1227
Jun 26, 2012.
Ok, you have the dual overhead cam motor. You need to check the belt. You are right at the time for replacing the belt. If it breaks, it will bend valves and complicate things.

Roy

ASEMaster6371
Jun 26, 2012.
OK SO WAT ELSE CAN IT BE?

Tiny
John1227
Jun 26, 2012.
When the engine cranks, does it sound odd? If the belt broke, you most likely have bent some valves.

No it cranks up like a regular car. It has new alt new battery and starter. The car was working fine and while I was drivin it just turnd off.

Tiny
John1227
Jun 26, 2012.
And the timing belt is new.

Tiny
John1227
Jun 26, 2012.
Have you checked the following: Spark (should be blue snapping spark)
Fuel and fuel pressure (should be within manufacturer's specs and
be getting a good pulsing power to each
injector)
Engine compression Should be within the manufacturer's spec.

If the belt broke, you could have bent valves.

Let me know what you have found.


AD