Mechanics

ENGINE NOT STARTING WITHOUT PRIME

1995 Chevrolet Blazer • 130,000 miles

I'm working on a 1995 Chevy S-10 Blazer w/a 4.3 liter engine. It wouldn't start w/o manually priming it & then it would stall out after the fuel I primed it with ran out or when accelerated past 1.5 RPMs. Put a fuel pressure gauge on it & it has 60 psi and maintains it. New parts installed in hopes to fix prob; EGR valve, removed fuel tank & cleaned, added fresh gas, flushed & cleaned fuel lines, installed new tank vent valve, installed new fuel pump strainer, installed new fuel pump filter & a new inline fuel filter, installed new fuel pressure regulator, installed a new fuel pressure relay, installed new coil, and installed new crank sensor. Now it starts with key w/o priming & idles great for hours. Motor sounds strong, but if u try to drive it. It stalls out & dies at 1.5 RPMs. It has good strong spark, great fuel pressure, and we also checked the spider injection system, and it has no leaks. We are STUCK! Please help! This is a time sensitive matter! Respond asap.


Thanks for this site, I love it.
Avatar
Lilbunnyfoofoo
December 6, 2011.




Are you getting power to the injectors?

Power to injectors? It starts & runs but not above 1500 rpms. What do you mean by, "Power to the injectors?"

Tiny
Lilbunnyfoofoo
Dec 6, 2011.
Jacobandnickolas,
You answered my above question with a question. You asked if I was getting power to the injectors? If it starts and runs fine and excellerates to 1500 rpm before stalling out and dieing. Wouldn't that mean that I have power to the injectors? I explained in detailin my orriginal question and listed all new parts & what all we done thus far. Please explain what you are meaning by power to the injectors. Thank You.

Tiny
Lilbunnyfoofoo
Dec 6, 2011.
These vehicles are know to have injector problems (the spider). That is where I would focus my attention. The symptoms you have described leads me to that.
AD

Ok. I was told to unbolt the plenium and expose the spyder injection system, and the turn key forward til I heard the fuel pump engage, and if there wasnt any fuel leaks, then the spyder was ok. I was told to inspect the spyders individual lines for brittleness & defects also. No defects or leaks present. Could it still be bad? And how do I check?

Tiny
Lilbunnyfoofoo
Dec 7, 2011.
Yes it could be bad. An injector or injectors may not be firing.

Ok. How do I check to see if its bad, or if all injectors are fireing? As you read in my orriginal description of the prob, I have replaced "ALOT" of parts already. I dont wanna spend $295.00 for a new spyder injection system and it not be the prob. This car has $100 parted me to the poor house! I tried to run a computer diagnostic on it with two different Oriely's diagnostic comps. Both read that there is (NO DATA) stored on my onboard computer? Any suggestions?

Tiny
Lilbunnyfoofoo
Dec 7, 2011.
It Wouldn't Start O Mannually Primeing It & Then Would Stall.

The pressure should be 60-66psi if it still stalling check and test the fuel pump and oil pressure sending unit-

Tiny
Rasmataz
Dec 7, 2011.
Ok. Now it starts with out primeing it. It idles for hours, but if you excellerate it to 1500rpms or beyond, it stalls out and dies. Fuel pressure is 60 psi and it maintains it. One of the online mechs said it wasnt getting power to injectors, but how is that if its starting & idleing and excellerates? It stalls out dies at or above 1500rpms. Fuel pump checked out fine, I cleaned tank and added fresh gas, installed new tank vent valve, installed new fuel pump strainer, installed new pump filter & inline fuel filter, installed new fuel pump relay, installed new pressure regulator, installed new crank sensor, installed a new EGR valve, and I installed new coil. Starts with key now, runs fine up to 1500 rpms, and then stalls out and dies. Any suggestions?

Tiny
Lilbunnyfoofoo
Dec 7, 2011.
Check and test the MAP and TPS sensors

Tiny
Rasmataz
Dec 7, 2011.

AD