Mechanics

SHIFTING ISSUE

1994 Saturn Station Wagon

Transmission problem
1994 Saturn Station Wagon 4 cyl Two Wheel Drive Automatic 170000 miles

Bought a tranny for this in december, finally got it in recently as well as a new fuel pump. Took it for a test ride and for about a mile or so, everything was great. Then the tranny would not shift up in to 3rd for some reason. Someone told me about the coolant temp sensor, so I removed it and it had a crack in it. Replaced it and the car ran much better, so I took off again and one more time, after about a mile n a half, same thing, would not go in to 3rd again.I has a fresh fluid change as well as filter.I had a buddy try and read its OBC, but he could not read it for some reason. His machine could not pull up anything. Any thoughts?Could really use the help since this is supposed to be my sons car. She runds very good and the body is as well, but this tranny issue is a pistol
Avatar
Wade_in_alabama
March 24, 2010.



Is the car a sw1 or sw2?What yr and model did ur donar transmission come out of?Let me know.

Saturntech9
Mar 25, 2010.
I am unsure if it is an SW1 or 2, but it is a 4cyl, DOHC. I am waiting on an answer of the year and model of the donor car, but I am pretty sure it was a 4 door 96 model. As soon as I have the info, I will post it on here, thanks for inquiring.

Tiny
Wade_in_alabama
Mar 25, 2010.
U have a sw2 let me know what yr and model sl1 sl2 sw1 sw2 etc that could be ur problem might have the wrong transmission in there they will bolt up just won't shift right. Talk to u soon.

Saturntech9
Mar 26, 2010.
Are you kidding me? That would totally suck if this is the problem. I did talk to a transmission guy who said that he thought it was the " jets" in it, but man if its the wrong one completely, I just wasted ALOT of money trying to get this going. Not that you have done anything wrong, but I was told that the tranny would fit in a car up to 96 model. I still have not heard from the guy about the actual year, but I expect to hear from him soon.
Thanks for your help. So far, lol.

Tiny
Wade_in_alabama
Mar 26, 2010.
Make sure u get the yr and model yeah differnt models have differnt gear ratios. Let me know and I'll help u out.

Saturntech9
Mar 26, 2010.
I finally got an answer. The tranny is from a 95 SL2. But I also have someone telling me that it may just be the shifting solenoids need replaced as well. I have this guy who is considered a tranny expert in the area who says he thinks that is what it is and can replace them whitout removing the engine or tranny to do it. Any thoughts about that?

Tiny
Wade_in_alabama
Mar 28, 2010.
First thing ur expert should have done before he is saying bad solindos was see if u had the right trans in ur car. Also how did he figure out if it was a bad solindo did he ohms check the solindos or ohms check ur bus plate or check ur wiring to the trans. Or even try to buzz the solindos to see if they buzzed normal or didnt buzz at all. Thats how u would properly check them. Here comes the bad news ur trans assembley part number for a 1994 dohc wagon is 21009455 and the part number for the 1995 dohc sl2 u have in there is 21009456 a differnt number I checked it twice on mitchel on demand. That could be ur problem right there I know a single cam and a dual cam transmission have differnt gear ratios.I dont know what the differnces are between the two transmissions but they have two differnt part numbers from the one u had to the one u put in.U can try to diagnose the trans but if its because of the wrong trans u will never fix it. Before he replaces the solindos I would be asking him the questions I asked u. Do u have a warranty on the trans or can they help u out since they gave u the wrong one?Let me know.

Saturntech9
Mar 28, 2010.
No he did not do any of the things you mentioned, but it was just based on what the car was doing in a conversation with him, and he said he thought it might be that, but was unsure. As far as the warranty, no, the guy did not offer one of those at all. I drove it this morning and all was well with it, no problem shifting at all, so now I am really lost. I will talk to this guy tomorrow and ask him if he could do the things you mention before we do something that is totally the wrong way. Thanks for your help though, I appreciate it immensely

Tiny
Wade_in_alabama
Mar 28, 2010.
Ok let me know what he comes up with and I'll make sure he treats u right.U can flash the codes out of the service engine soon light. On ur obd connector top row far right the two end pins that are right next to each other jump those together with the key in the run postion the light will flash u will get a single flash then two quick ones meaning code 12 that will repeat 3 times that code means ur computer is good. Then if u have any other codes for example if u got two quick flashes followed by three quick ones would mean code 23 that would repeat 3 times then go to the next code till u got back to the code 12 meaning that's the end of ur codes. Let me know if u have any codes.

Saturntech9
Mar 29, 2010.
My son just bought a 94 sw2. Check engine light comes on after slowing down then wont shift from 2nd to 3rd. Pull over turn car off and its fine. Almost like its going into limp mode. When I checked the codes with engine light on it was 23 no 3rd gear. Only happens when check engine light comes on. Also when you shift from park to reverse you have to step on the gas to get it to go into reverse? Any idea, I'm really stump with it? Thanks

Tiny
Brentkay73
Jan 8, 2012.
Page 1 of 2