Mechanics

ENGINE STARTS BUT DIES AFTER A FEW SECONDS

1994 Jeep Grand Cherokee • 6 cylinder 4WD Automatic • 223,000 miles

Hi guys. I have a 1994 Jeep grand cherokee laredo 4x4 6cyl. I just recently bought this jeep it ran then it wouldnt start then ran fine again. I did a tune up of plug wires, plugs, cap, rotor, coil, pick up coil, crank sensor. It ran fine for a day and wouldnt start after that. Fuel pump works and great pressure. Relays are all good and the same with the fuses. It would crank over but no spark to the coil. Then we found a used ignition control module {brain box} from the same yr. Model and options mine has for $35.00 and not $650.00 new. Now it starts up but dies a few seconds after like I turned the key off. Still good fuel pressure and relays. It has a security system but I dont know how it works. Im kinda lost now. Any ideas? Thanks guys!
Avatar
PLOCO
November 19, 2010.



Have you checked the crank sensor? Also, is it an aftermarket alarm? I don't recall a factory alarm came with them in 94. Let me know.

Joe

I replaced the crank sensor. Also there is an aftermarket alarm installed. I tryed turning switches off an then starting jeep but still doing the same.

Tiny
PLOCO
Nov 19, 2010.
Maybe the asd relay? I swapped relays but the same starts up but dies after a few seconds. Anybody got any ideas? Lol. Thanks.

Tiny
PLOCO
Nov 20, 2010.
This is a tough one with an aftermarket alarm. God knows what one it is. Have you been able to check to see if spark is being lost to kill the engine or fuel pressure? I realize it shows good at first, but one is killing the engine after a few seconds.

As far as the ASD, if it was bad, the vehicle wouldn't start at all.

The fuel is good but the spark cuts out just after start up.

Tiny
PLOCO
Nov 20, 2010.
No knowing what kind of an alarm system you have, can you tell how to disconnect it?