Mechanics

WHY IS IT FLOODING?

1994 Isuzu Trooper • 175,000 miles

1994 Isuzu Trooper 3.2LSOHC 4door, AutoTrans, has New injectors(6), Plugs(6) & wires, ECU, coils(3), Crank Sensor, Timing belt, water pump, radiator, O2 sensor, Speed Sensor, Idle Air Control, Pressure Regulator, Ignition control module, fuel filter, pvc, Air Intake Temperature sensor. I had all the stuff replaces before daughter headed off to College and was driving fine, after 4000 miles trooper just died while driving down road.
I replaced fuel pump, ignition switch, and EMC. When I turn, the key I can hear fuel injectors spray but will not start due to flooding (it does have spark). Sometimes it will start for about 2 sec then floods out. Fuel pressure gauge shows 39-40lbs. What else could it be? I have replaced so much stuff, I think I got fix it to get my money out of it just in parts.
Avatar
Jjgreen73
March 9, 2012.




You did not mention Engine Coolant Temperature sensor and if it has not been checked, do so.

Check the injector circuit for shorting to ground which would cause the injectors to be opened fully when ignition is turned on.


KHLow2008
Mar 9, 2012.
I'll check/replace Engine Coolant Temp. Sensor today and see where that takes me, checking for ground short that going to take me while. I'll keep an update and post findings.
AD


Tiny
Jjgreen73
Mar 10, 2012.
We'll be here. Let us know what you find out.
KHLow, can you post the engine performance schematic for him? Isn't letting me see any of the schematics for this vehicle.


Rivermikerat
Mar 12, 2012.
Here they are.

Mike, what problem are you getting with Mitchell1? Did you install sg view?


KHLow2008
Mar 13, 2012.
I gave up on it and had it towed to local mechanic shop. I'll pay someone to trace out the wires and test them. I'll post the findings or the link to cragslist where it getting sold for parts. LOL

Thanks


Tiny
Jjgreen73
Mar 13, 2012.
Mit1 is picking and choosing which schematics for which vehicles I get to see and which I don't.


Rivermikerat
Mar 14, 2012.
For wiring problems, patience is one of the most important factor.

Good luck.

Something must be wrong somewhere with Mit1. Let Mike knows, maybe he can help.


KHLow2008
Mar 15, 2012.
I've told him about it a few times.


Rivermikerat
Mar 16, 2012.
--Update--

Got 94 Trooper back from shop, some how the timing jumped. Had them redo the timing and it fires right up and runs. I did notice that the 'CheckTrans' light is flashing and Alt is only at 10 volts. I am hoping that a new Alt will fix the Trans light. I drove it home and shifted fine until battery started to discharge then started to shift harder. That where I am at now.

Thanks everyone for the help!


Tiny
Jjgreen73
Mar 23, 2012.
Yeah, get the battery fully charged, Check the alternator output and change it if necessary, then see what happens.


Rivermikerat
Mar 24, 2012.

AD