Mechanics

ANTI-LOCK BREAK LIGHT AND SERVICE ENGINE LIGHT

1993 Oldsmobile Delta 88 • 124,000 miles

The anti-lock break light stays on constantly, and sometimes if I punch the gas to go faster the service light engine comes on and the car loses a little power and sometimes will just completely shut off with no warning. What can this be caused by?
AD
Avatar
Kat12312
September 19, 2011.



The first thing you need to do is see what abs and engine codes you have get back to me with the exqct code numbers you have.


Saturntech9
Sep 19, 2011.
I was doing some research and it seems to be the torque converter clutch solenoid, I was told for an easy fix to unplug the four prong connector on the transmission which I do not know where that is? Was wondering if anyone has a picture or exact whereabouts? Thanks


Tiny
Kat12312
Nov 6, 2011.
You never told me which codes you have?Also what size engine do you have?


Saturntech9
Nov 6, 2011.
3.8-liter V-6 is the engine, did not get the codes tried doing that with a mechanic I know and he could not find anything so went somewhere else and this is what I was told to do if I did not want to pay almost 500 dollars to get it replaced


Tiny
Kat12312
Nov 6, 2011.
So without even getting codes your going to take wild guess and just replace a part?


Saturntech9
Nov 6, 2011.
Had codes checked by mechanic was told it was that part and to just pull trans plugue to no money to fix it?
AD


Tiny
Kat12312
Nov 6, 2011.
I posted a diagram of where the tcc solenoid is its in the side of the valve body.


Saturntech9
Nov 7, 2011.

AD