Mechanics

OLDSMOBILE 88 FUSE PROBLEM

1993 Oldsmobile 88 • 142,000 miles

Car shut off while driving, w/out warning. Towed home and fuel pump didn't/doesn't seem to be working then discovered fuel pump relay wasn't getting signal. Not quite sure where or how to trouble shoot or where look for fixing it.
Avatar
MargaretPD
November 20, 2012.




My info shows an oil pressure switch in the fuel pump circuit, just a redundant power supply. Once you crank it enough to bring up oil pressure and that switch closes, the pump will run regardless of relay. Voltage for the load side of relay and o/p switch, comes from the same fuse. Check the fuse and voltage on the fuse circuit. Fuse number 6--20 amp in relay center.


JDL
Nov 20, 2012.
Thanks for your reply. That is helpful. I checked the fuses in the small panel next to the passenger door. I have no power to all of the fuses on the lower row (numbers 5, 6, 7, 8). Is there something I should look for to resolve that issue. I do know that when you disturb the system the car wont start for about 30 minutes. Thanks for your help.
AD


Tiny
MargaretPD
Nov 20, 2012.
The passenger compartment relay center says to be behind right side of dash. Not sure you looking in the right place for that fuse?

Some fuses are hot all the time. Some fuses go hot when you turn on the key.

Any applicable trouble codes, you should be able to check mil codes, yourself. You use a jumper wire between A & B terminals at the datalink connector. Turn key just till dash lites come on, no further, no crank. Then the mil starts flashing, you count the flashes to get the codes. Your looking for two digit codes.


JDL
Nov 20, 2012.

AD