Mechanics

STALLS WHEN GAS IS PUSHED

1991 Oldsmobile Cutlass • 150,000 miles

MY 1991 OLDS CUTLASS SUPREME SL 3.1 MPFI AUTOMATIC FROUNT WHEEL DRIVE RUNS GREAT ILDES GREAT LOTS OF POWER. BUT WHEN IT WORMES UP EVERY TIME I STOP THEN TAKE OFF IT CUTS OUT ENGINEMISES AND DIES. TO RESTART I HAVE TO FLOURE THE GAS I TESTED LOTS OF STUFF NEED TO START FROM SCRATCH.
Avatar
Bart koski
June 20, 2012.




Ok first off how old is the fuel filter? What have you tested and what have you replaced at this point?

Racefan966
Jun 20, 2012.
I TESTED THE O2 SENSOR(.80VOLTS TO EXHAUST.28 TO EMC.80 WITH THEM CONNECTED)
IAC(58OLMS BOTH READINGS CAR NOT RUNNING)(880OLMS BOTH WITH RUNNING)
MAP(B&C TERMNIALS5.04 VOLTS)(B&A 4.5)CAR RUNNING(2.3 IDLE)(1.69 WIDE OPEN, HIGH RPM)
EGR NEW GASKET & ENERGIZED EACH OF THE THREE SILOIDS, THEY WORKED.
CHECKED THE CAT, VACUUM LINES, GAS PRESSURE, PLUGS & WIRES,
THE FULE FILTER & MAP ARE NEW.
I GUESS THE CRANK &CAMSHAFT SENSORS ARE NEXT? I KNOW WERE THE CRANKSHAFT SENSOR IS NOT THE CAM OR HOW TO TEST.

Tiny
Bart koski
Jun 20, 2012.
No don't go parts chasing it cost to much and I do not believe in it as a mechanic. I do believe this car has a mass air flow unit so get some mass air flow cleaner and remove it and spray the inside to clean it. If that don't help then let me know and I will tell you how to test it to see if it is bad, if that checks out then we will test the crank and cam sensors ok.

Racefan966
Jun 20, 2012.
Thank you for your help.I dont see a maf. Only something that looks like a o2 sensor but half the size, ppluges unto air duct under the filter.

Tiny
Bart koski
Jun 20, 2012.
Nope no mass air flow on your car. Do you have a digital multi meter? If so I can walk you through a test on the TPS and the air charge temp sensor too (that is what is in the air intake hose).

Racefan966
Jun 21, 2012.
OK im ready. Ive been under this hood for about a week and ahalf
and my 18year old dautgh doesnt like driving my truck. She is due in december. But with your help the car will be done soon.
Thank you for all your help.

Tiny
Bart koski
Jun 21, 2012.
Chilton says I should get less then 1.25 in idle I got.69. Wide open 5voltz I got 1.37 if I did it right
it doesent say about cranck or cam

Tiny
Bart koski
Jun 21, 2012.
Ok that sounds about right for the TPS. Now if you would ohm the air charge temp sensor thats the sensor in the air intake hose. Let me know what you find and we go from there.

Racefan966
Jun 21, 2012.
At setting20k I got 2.17olms. Thats the air charge temp sensor. What should it be? I tested it unpluged key off.
AD

Tiny
Bart koski
Jun 21, 2012.
I thought the reading for tps wide open throdle was low?

Tiny
Bart koski
Jun 21, 2012.

AD