Mechanics

CUTS OUT GOING DOWN THE ROAD

1989 Chevrolet Celebrity • 145,000 miles

Going down the road or sitting in the garage holding the throttle at about 1400 rpm or so, ( rpms dont mater) the engine cuts out (skips)

The analyzer shows codes 22 &34 , TPS & MAP replaced both and still does it. And still shows 22 &34. After clearing codes and running again.
Checked vacume lines found a couple spots that were rubbed thin but not thru put some tape on the spots to see if it were a possible leak no change.

I cant find a shrader valve to chack the fuel press. So how do I go about doing that?

Pulling my hair out at this point and the wife is pissed I havnt fixed her car yet!
Avatar
Zenaca
April 29, 2012.



With the key on check the voltage on all 3 wires @ the tps and map sensor let me know what thay are. Is this the 4 cyl or v6?

Djcl
Apr 29, 2012.
2.5 4cyl

Tiny
Zenaca
Apr 29, 2012.
Check the voltage on the 3 wires

Djcl
Apr 29, 2012.
With the key on engine not running reading from each pin, meter grounded to alternator housing
TPS
blue & black wires read.01 volt set on 20volt on meter
grey wire read.00

MAP
A &B read.01 volt
C read.00

Tiny
Zenaca
Apr 29, 2012.
Your missing the 5 volt refference signal on the to sensors. That gray wire must have 5 volts out of the pcm to the sensor

Djcl
Apr 29, 2012.
What are the chances it is both wires to the sensors as opposed to being the pcm bad?

Tiny
Zenaca
Apr 29, 2012.
Thay share the same 5 volts if its missing @ the computer check all your powers and grounds

Djcl
Apr 29, 2012.
I have another one of those cars I swapped computers, same problem.

So I tried moving the wire harness where it comes out of the fire wall while it was running and it smoothed out, so I guess I just have to figure out which wire and where it is bad.
And there is SOOO much room to work in there this is going to be fun.

Thank You for all the help !

Tiny
Zenaca
Apr 29, 2012.
Your welcome let me know if you need more help

Djcl
Apr 30, 2012.