Mechanics

ENGINE HAS A BAD MISS AND POOR IDLE

1984 Ford F-150 • V8 2WD Automatic • 190,000 miles

I have a 1984 F150 5.8 with no power on 2 cyls #5&8 this is a 4bbl auto trans with new or less than 1 yr old carb, dist, control module, plugs, wires, cap & rotor, coil, elec fuel pump. I have 125-130 compression on all cyls and spark through all wires. However truck runs the same with or without 5 & 8 wires connected to dist. Please help. Thank You from Plumbfire
Avatar
Plumbfire
April 13, 2011.




Usually something dumb! Even New stuff can be bad, and stuff being a year old could be bad too!

How long ago did this become an issue?

Been Timed?

Have you switched wires around (meaning swapping 5 and 8's, wires to other cylinders and seeing if they act the same on different cylinders?

Have you adjusted the carb mixtures. Have tuning tools? Or by ear?

This is all the time or just idle?

With dist. Cap off, is the rotor button shaft "Solid" or can you "Wobble" it at all, with your fingers?

If you squirt/ dribble a little fuel in the carb (passenger side barrel) with a mist bottle, ETC.--Does it change anything? Do this Outside, Fire fighting equipment handy!

Hope I can help you.

Your Turn

The Medic

If you have the ign. Module tested, do it 5-8 times in a row, if it fails the last few replace it---Test the new one the same way before you leave the store (Don't ask/ go there!)

Tiny
CJ MEDEVAC
Apr 13, 2011.
: D You've returned one too many "new" modules also CJ?
AD

Tiny
Dwb812
Apr 14, 2011.
Dwb812 CHECK YOUR MESSAGES, SENT YOU ONE (CLICK ON YOUR NAME AFTER YOU LOG IN--LOOK LEFT)--THE MEDIC

Tiny
CJ MEDEVAC
Apr 15, 2011.

AD