Turn signals not working

Tiny
SARNOLD2426
  • 2004 OLDSMOBILE ALERO
  • 4.6L
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 140,000 MILES

I have just replaced the hazard switch in it. Now the turn signals will not come on. I have also replace the turn signal controller due to the wiper control arm was broken. So any help would be helpful.

Do you
have the same problem?
Yes
No
Friday, March 10th, 2017 AT 2:23 PM

17 Replies

Tiny
KHLOW2008
  • EXPERT
  • 42,045 POSTS

Have you checked the fuse for the turn signals?
Are the hazard lights working?

Was this
answer
helpful?
Yes
No
Sunday, March 12th, 2017 AT 1:44 AM
Tiny
SARNOLD2426
  • MEMBER

After replacing everything, I later learned that the turn signals have not been working for the past few days prior of me replacing everything. Yes I did check all the fuses and everything check out okay. Also, the hazard switch is working as well. So at this point I am leaning towards that there is a short somewhere in wiring.

Was this
answer
helpful?
Yes
No
Monday, March 13th, 2017 AT 1:16 PM
Tiny
2CARPROS KEN
  • ADMIN
  • 11,708 POSTS

Hello,

There is a auto park lamp control relay that looks like it controls the power to the turn signals that could be out, here is a guide and a diagram that can help you get the problem fixed. Also you can check for power and see if you are loosing it somewhere.

https://www.2carpros.com/articles/how-to-check-an-electrical-relay-and-wiring-control-circuit

and

https://www.2carpros.com/articles/how-to-use-a-test-light-circuit-tester

Please run this test and get back to us so we can continue helping you.

Best, Ken

Was this
answer
helpful?
Yes
No
Thursday, March 16th, 2017 AT 11:40 AM
Tiny
ANNE4670
  • 2004 OLDSMOBILE ALERO

2004 Oldsmobile Alero

We have a problem with the turn signal not working at different times (when it is raining or the air conditioner is on and it causes moisture). My husband has checked a few things, but still we would like more advice on how to fix it so we don't have to stick our arm out the window. Can you give a suggestion on what to try?

Was this
answer
helpful?
Yes
No
Thursday, March 16th, 2017 AT 1:08 PM (Merged)
Tiny
JACOBANDNICKOLAS
  • EXPERT
  • 68,395 POSTS

When it doesn't work, do you mean it doesn't flash or doesn't work at all?

Was this
answer
helpful?
Yes
No
Thursday, March 16th, 2017 AT 1:08 PM (Merged)
Tiny
ANNE4670
  • MEMBER

Our turn signal does not work at all at iffeerent times

Was this
answer
helpful?
Yes
No
Thursday, March 16th, 2017 AT 1:08 PM (Merged)
Tiny
JACOBANDNICKOLAS
  • EXPERT
  • 68,395 POSTS

If they don't work at all, I would start at the switch in the steering column.

Was this
answer
helpful?
Yes
No
Thursday, March 16th, 2017 AT 1:08 PM (Merged)
Tiny
SNUPCAKE
  • 2003 OLDSMOBILE ALERO
  • 76 MILES

I have a 2003 olds alero w 76k miles. Just recently the following things have started happening. The turn signal goes ticka-ticka-ticka when it should shut off. The blower is not working well, it only works on high, and the lighter/outlet thing doesn't work if I plug anything in. Is this a sign that something big is going on or are these little unrelated things.

Was this
answer
helpful?
Yes
No
Thursday, March 16th, 2017 AT 1:08 PM (Merged)
Tiny
HMAC300
  • EXPERT
  • 49,780 POSTS

They could be unrelated. Check your fuses for the lighter and body to battery ground for the flasher. You could have a bad flasher as well. For the blower check your resistor, it should be by the blower, see if it is getting and putting power out, it may not be. If it's not getting power check the control head.

Was this
answer
helpful?
Yes
No
Thursday, March 16th, 2017 AT 1:08 PM (Merged)
Tiny
JACOBANDNICKOLAS
  • EXPERT
  • 68,395 POSTS

If the signals are not canceling, chances are the plastic tab that shuts them off when the steering wheel centers is broken. If the blower motor only works on high, chance are either you have a bad blower motor resister or relay. Finally, check for a blown fuse to the lighter. Check to see if there is power to the lighter. There should only be one wire going to it.

Was this
answer
helpful?
Yes
No
Thursday, March 16th, 2017 AT 1:08 PM (Merged)
Tiny
TWINKIEDELIGHT05
  • 2002 OLDSMOBILE ALERO
  • 2WD
  • AUTOMATIC
  • 150,000 MILES

When you go to turn on the blinker sometimes they dont' work. But if they don't come on an you turn the fourways on an leave them on while you turn the blinker on an then turn four ways off the blinker will blink. But for some reason now that even though the blinker isn't on the ticking noise that the blinker makes while blinking ticks as if the blinker is on an it isn't. Any solutions

Was this
answer
helpful?
Yes
No
Thursday, March 16th, 2017 AT 1:08 PM (Merged)
Tiny
FIXITMR
  • MEMBER

Try lubing hazzard switch. It interacts with turn signals. Or just replace it? You also may have a bad multi sitch which is your turn signal assembly. Could be wire loose or bent contact, etc.

Was this
answer
helpful?
Yes
No
Thursday, March 16th, 2017 AT 1:08 PM (Merged)
Tiny
SIMON10
  • MEMBER

If you haven't already got the issue fixed, try calling a gm service tech and provide them with your vin number. I have a 2000 that did the same thing and it was recalled so they fixed it for free. It has something to do with bad soldering.

Was this
answer
helpful?
Yes
No
Thursday, March 16th, 2017 AT 1:08 PM (Merged)
Tiny
  • 2000 OLDSMOBILE ALERO
  • 130,000 MILES

My alero just had the turn signals outside and the dash indicators suddenly not work. Upon trying to figure out why I noticed my running lights were also not working. Then just as quickly as they stopped working they started working fine again. What is causing this so I can get it fixed asap?

Was this
answer
helpful?
Yes
No
Thursday, March 16th, 2017 AT 1:08 PM (Merged)
Tiny
ASEMASTER6371
  • EXPERT
  • 25,483 POSTS

Bad connection somewhere. Check all scokets and bulbs.

Roy

Was this
answer
helpful?
Yes
No
Thursday, March 16th, 2017 AT 1:08 PM (Merged)
Tiny
MALACY0349
  • 2002 OLDSMOBILE ALERO
  • 2.2L
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 115,000 MILES

For a while the turn signals would work but one day it stopped working the majority of the time.

Now the turn signals have become irregular in their functioning. Some times they will not come on, other times they will work like they are supposed to and even weirder is quite often a solid hit on the dashboard right above the gauges will bring them back on.

Any ideas?

Was this
answer
helpful?
Yes
No
Thursday, March 16th, 2017 AT 1:08 PM (Merged)
Tiny
HMAC300
  • EXPERT
  • 49,780 POSTS

It might be a loose connection at dash, or it jars the hazard switch where your flasher is. Or coincidental

Was this
answer
helpful?
Yes
No
Thursday, March 16th, 2017 AT 1:08 PM (Merged)

Please login or register to post a reply.

Recommended Guides