2000 Subaru Outback power window button

  • 1 POST

Electrical problem
2000 Subaru Outback

About 6 months ago my drivers side window started being problematic. It always could roll down, but I had to jiggle the button to get it to roll up. As time passed, this jiggle became more difficult to pinpoint. However, there were consistent aspects that I noticed about whatever particular maneuver this button required in order to successfully roll my window up.

1. When I pressed the driver side window button to roll the window down, I could hear (what I call) the drain that it made on the battery just like all the other buttons for the other windows in my car. I began to notice that it was when I pulled the button back to roll it UP that there was NO change in the way my car sounded, even though the other window buttons did.

2. Sometimes I could pull the button back to roll the window up and then ever so slightly release it just enough to get the window to start going up. This was a very intricate and sensitive procedure.

3. Sometimes if I opened my car door and jiggle the tube thing that held the wires going wherever they go, closed my door, and tried a few more times, it was easier to find that button's proper position.

4. Sometimes if I pretended not to be paying attention to how frustrated I was at the window button for not working - the button fell for it, I would hear the motor whir in the window and it would roll up suddenly.

I recently took my car to a mechanic because I was having to spend a lot of time working that button and it was getting cold and rainy. Contrary to my perspective on the issue, he said it was the motor that needed replaced. (I couldn't understand how it could be the motor if the other windows worked fine and it rolled down really well. But I ordered one anyway.) Today I got my car back because he found that it wasn't the motor and now I am looking at the button mechanism and control panel here on my dining room table. Now none of my windows can be rolled down. They are up for good until I figure out what to do.

I am wondering is there any way to look under that one button and make sure that it is hitting where it is supposed to in order to engage in rolling up the window?

Do you
have the same problem?
Sunday, October 31st, 2010 AT 12:18 PM

0 Replies

Please login or register to post a reply.

Recommended Guides