1991 Subaru Legacy Is my transmission going out?

Tiny
IZZYAZ
  • MEMBER
  • 1991 SUBARU LEGACY
  • 4 CYL
  • AWD
  • AUTOMATIC
  • 157,333 MILES
My front-right CV joint went out on me about a month ago. While it was beginning to go out, the transmission started to slip. When my CV joint broke, the transmission would not let my car go past 37mph. It seems like too much of a coincidence. If I replaced my CV joint, would that fix my transmission issue? Does the CV joint tie in with this problem or is my transmission just bad?
Do you
have the same problem?
Yes
No
Saturday, December 6th, 2008 AT 8:02 PM

3 Replies

Tiny
OBXAUTOMEDIC
  • EXPERT
Hello,

Have you checked the level of your tranny fluid? If you have been running around on a bad CV Axle it has most likely damaged the seal and has been leaking tranny fluid.

Post findings here in forum.

.
Was this
answer
helpful?
Yes
No
Saturday, December 6th, 2008 AT 8:29 PM
Tiny
IZZYAZ
  • MEMBER
The tranny fluid is fine, that was one of the first things I checked. The seal is good. I took out the CV joint out and put a cap on the hole in the tranny. So that cant be the problem. Anything else that could be wrong?
Was this
answer
helpful?
Yes
No
Saturday, December 6th, 2008 AT 10:55 PM
Tiny
OBXAUTOMEDIC
  • EXPERT
Ok, when was your last transmission service with fluid and filter change. Does the fluid look brownish and smell burnt? If so change filter and fluid.

It is also possible that the CV Axle not being there is causing your problem. It could have cause some internal damage. With the axle missing it is causing more stress on the other axle by making it do more work instead of distributing the work.

You may be best off taking it to a transmission shop to find out for sure. Or call a few and see what they have to say.
Was this
answer
helpful?
Yes
No
Sunday, December 7th, 2008 AT 10:14 PM

Please login or register to post a reply.

Recommended Guides