Idles fine but in gear shuts off

Tiny
73SATELLIET
  • MEMBER
  • PLYMOUTH
73 plymouth satellite
318 2bbl carter all stock
Ok got my carb cleaned and put back on. I thought I was having a tunning issue but its way beyond that. I am really at a loss for what to test.
It idles high and stalls out when put in gear.
Like instantly no matter how I feather the gas from nuetral to reverse or drive.
The only time its happy in in park or nuetral. Its still idles high feels likes its missing but still.
I have checked all vaccuum hoses and since its idling I dont think its fuel sending issue.
I need ideas. Electrical? Transmission?
318 2bbl carter all stock
The previous owner installed a tach in front of the center console. While replacing a fuse I inadvertenly disconnect power to the tach but I wasnt worried about it. Reconnecting the tach I am not sure if it was coincidence or what but the car started backfiring when given gas. We disconnected the coil thereby killing the tach again and the backfiring went away.
Still the stalling remains. The transmission linkage slides into gear but is very forceful going into reverse and drive (feels like a launch) and then stalls just as if I cut the key off while giving it gas and putting it into gear. Automatically off even while feathering the gas.
Do you
have the same problem?
Yes
No
Monday, June 25th, 2007 AT 8:18 AM

1 Reply

Tiny
JACOBANDNICKOLAS
  • EXPERT
This sounds like a problem with the trans. When you place it in gear, does it feel like you are letting the clutch out on standard trasn?
Was this
answer
helpful?
Yes
No
Sunday, March 22nd, 2009 AT 12:32 PM

Please login or register to post a reply.

Sponsored links