1990 Oldsmobile Cutlass Car just stops running

Tiny
MYSTRYMEAT
  • MEMBER
  • 1990 OLDSMOBILE CUTLASS
Computer problem
1990 Oldsmobile Cutlass 6 cyl Two Wheel Drive Automatic 100+ miles

My car started just shutting off every once in a while after I would come to a stop. As time went on it would do it more and more even when just driving at highway speeds it would just turn off. It wouldn�t sputter or hesitate, just turn off like I turned off the key. Sometime I could just re--start it and be on my way other times I would have to wait for a few min up to 15 min or so before it would start. I started noticing that after it would get to a certain temp is when it would happen but once again I usually could just start it back up. I did notice that when I would turn on the heater that it would shut off faster. Im thinking since it�s the computer is mounted just above the heater fan that the computer is my problem. I did check the fuel pressure when it died and I always had fuel just no spark. I was thinking maybe the pickup that tells the computer to fire may be bad but once again it seems to be effected by heat. So I've pulled the dash apart to get to the computer but im not sure what numbers are the ones I should grab off the computer in order to order a new one. This is a 3800 v6 with air.
Any help with this would be great.
Thanks.
Do you
have the same problem?
Yes
No
Monday, August 23rd, 2010 AT 10:24 AM

1 Reply

Tiny
JACOBANDNICKOLAS
  • EXPERT
Have you checked the crank sensor?
Was this
answer
helpful?
Yes
No
Monday, September 6th, 2010 AT 12:07 AM

Please login or register to post a reply.

Recommended Guides