1990 Oldsmobile Ciera Fuel pump wont pump fuel unless hot j

Tiny
NOTAPROMIKE
  • MEMBER
  • 1990 OLDSMOBILE CIERA
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 242,000 MILES
Fuel Pump Relay is getting no power. When I run a jumper to the red connector at the fuel pump relay and then jump this hot wire to the grey wire connector at the fuel pump relay, the fuel pump runs and the car runs. Is there a fuse before the fuel pump relay? Is it the grey wire that is to be energized at the f.P. Relay and not the red one? Help. Thanks. Mike
Do you
have the same problem?
Yes
No
Saturday, April 3rd, 2010 AT 10:02 PM

4 Replies

Tiny
JACK42
  • MEMBER
That should be a 4 wire relay. Use a test light to figure this out.2 wires should have power, one of the others goes to tehpump and the other to theECM (Ground signal). The other one should go to ground when engine is turned on (momentarily) then stay on when running. This vehicle uses an oil pressure switch to interrrupt the fuel pressure to prevent engine damage, so be sure that the oil pressure sender is plugged in and working properly as well. According to my wiring it has a fuse near the starter, but doesnt give an exact location.
Was this
answer
helpful?
Yes
No
Tuesday, April 6th, 2010 AT 7:42 AM
Tiny
NOTAPROMIKE
  • MEMBER
Was this
answer
helpful?
Yes
No
Monday, April 19th, 2010 AT 7:21 PM
Tiny
NOTAPROMIKE
  • MEMBER
Thank you. The fusable link was burned out near the starter as you said. Very happy. Thanks. Saved me $$$$$
Was this
answer
helpful?
Yes
No
Monday, April 19th, 2010 AT 10:17 PM
Tiny
JACK42
  • MEMBER
Nice, glad to hear you found it
Was this
answer
helpful?
Yes
No
Tuesday, April 20th, 2010 AT 7:39 AM

Please login or register to post a reply.

Recommended Guides