1998 Oldsmobile 88 98 olds 88 lots of problems in the last

Tiny
HWENICK
  • MEMBER
  • 1998 OLDSMOBILE 88
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 121,938 MILES
A few months ago, my upper rad hose blew. I had that replaced along with the thermostat. It gets hot still not to the red but still warmer than it should be. There are no puddles to be found anywhere on the ground. Had a pressure test done and it was losing some but not alot so we changed the radiator cap. A few weeks later the check engine light came on and the car had no power. The next day it wouldnt start. Fuel pump filter and regulator were replaced. It had something called cylinder wash and the injectors were cleaned. Gave it a tune up and an oil change. Now again.I am losing coolant with no puddles and the car is very hard to start and will stall out. It idles between 1000 and 2000 rpms. The check engine light came back on this morning and it says P0306 which is a misfire. I dont know where to even begin and of course my mechanic who fixed my car before is not returning my phone calls. I have not changed the wires or coil yet but that will be my starting point. My gas mileage at this point is ridiculous 1/8 tank in about 10 miles. Just to and from work and my daughter's school which isnt that far.
Do you
have the same problem?
Yes
No
Thursday, April 29th, 2010 AT 2:17 PM

1 Reply

Tiny
TMIKE876
  • MEMBER
We just sold our 98 Olds 88 today(about 30 minutes ago). The intake on this model generates a lot of heat and there a plastic heater hose that cracks after a while. This could be the source of your coolant leak. It is located near the water pump and appears to go into the block. The part is only about $4 plus tax @ Napa or Autozone. I'll think about the power/mpg issue and ask a few friends. If I can find an answer I'll let you know. Good luck!
Was this
answer
helpful?
Yes
No
Friday, February 17th, 2012 AT 4:11 AM

Please login or register to post a reply.

Recommended Guides