Oil pressure warning light keeps flashing red with three long beeps while driving

Tiny
AYMAN123
  • 2004 VOLKSWAGEN POLO
  • 84,000 MILES

The oil pressure warning light keeps flashing red with three long beeps while driving when the temperature near or at operating temperature and it disappears for a while and then comes again I had this problem for 6 months the sensor and the electric wires are working good I don't know what to do.

Do you
have the same problem?
Yes
No
Sunday, November 10th, 2013 AT 2:04 PM

25 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
  • 68,313 POSTS

Have you checked the oil pressure with a mechanical gauge?

Was this
answer
helpful?
Yes
No
+8
Sunday, November 10th, 2013 AT 5:23 PM
Tiny
EXOVCDS
  • MEMBER

Since it only happens once the engine is war (oil is thinner / develops less pressure), you have a pressure problem.

Remove the oil pan and check the pick-up screen to see if it is clogged with debris / coked oil deposits.

If the screen is clean, check the crank & connecting rod bearings for wear.

Replace the oil filter if it has more than 15k km on it (you can try that first, before doing the above).

Thomas

Was this
answer
helpful?
Yes
No
-2
Monday, November 11th, 2013 AT 10:06 AM
Tiny
AYMAN123
  • MEMBER

No I did not check it with a mechanical gauge.

Was this
answer
helpful?
Yes
No
Thursday, November 14th, 2013 AT 1:24 PM
Tiny
AYMAN123
  • MEMBER

Thanks I will try that.

Was this
answer
helpful?
Yes
No
+1
Thursday, November 14th, 2013 AT 1:33 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
  • 68,313 POSTS

By checking it with a mechanical gauge, we will know if the pressure is really getting too low or if there us a sensor issue. Let me know what you find.

Was this
answer
helpful?
Yes
No
Thursday, November 14th, 2013 AT 3:18 PM
Tiny
AYMAN123
  • MEMBER

I checked it with a mechanical gauge and the pressure is getting low.
The engine vibrates when it is idle and the exhaust gases are getting out intermittently like tof tof tof not smooth is this related.

Was this
answer
helpful?
Yes
No
Saturday, November 16th, 2013 AT 2:22 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
  • 68,313 POSTS

What is the oil pressure at an idle?

Was this
answer
helpful?
Yes
No
+2
Saturday, November 16th, 2013 AT 3:42 PM
Tiny
AYMAN123
  • MEMBER

The oil pressure 1/4 at idle

Was this
answer
helpful?
Yes
No
-2
Sunday, November 17th, 2013 AT 1:16 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
  • 68,313 POSTS

How many PSI is 1/4?

Was this
answer
helpful?
Yes
No
-1
Sunday, November 17th, 2013 AT 3:11 PM
Tiny
AYMAN123
  • MEMBER

About 25 psi

Was this
answer
helpful?
Yes
No
+1
Monday, November 18th, 2013 AT 11:57 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
  • 68,313 POSTS

If you have 25psi at an idle, that is actually okay. It should increase if you rev the engine. Based on what you are telling me, it sounds like you have a bad oil pressure switch.

Was this
answer
helpful?
Yes
No
+2
Monday, November 18th, 2013 AT 5:22 PM
Tiny
KELLY MOORE2
  • 2007 VOLKSWAGEN POLO
  • 1.4L
  • TURBO
  • MANUAL
  • 145,000 MILES
  • MERGED

I was driving to work and I felt a bit of a bump but did not think much of it, then a red flashing oil light came on on the dash. I parked it up and after work went to drive it home. When I turned on the car it seemed normal and the oil light was gone but the engine was very cold and the car was juttering. As I was driving the red oil light came back on and a very loud metallic noise was coming from the engine. I drove about one kilometer and the car lost all power and the engine cut out. I could not restart the car. I checked the oil and the oil level was perfect. I had to get it towed away. Now I am worried that an oil pump or something failed and caused my engine to seize. Any ideas?

Was this
answer
helpful?
Yes
No
Wednesday, May 24th, 2017 AT 1:25 PM
Tiny
2CARPROS KEN
  • ADMIN
  • 6,954 POSTS
  • MERGED

Hello,

Yep it sounds like the oil pump lost pressure and the engine seized up. Here is a guide that will help you understand what happened.

https://www.2carpros.com/articles/high-or-low-engine-oil-pressure

Please let us know what happens.

Cheers, Ken

Was this
answer
helpful?
Yes
No
Wednesday, May 24th, 2017 AT 1:25 PM
Tiny
MARC19731
  • 2008 VOLKSWAGEN POLO
  • 60,000 MILES
  • MERGED

1.4 TDI. When the engine is cold I turn the ignition, start the engine and the amber oil warning light is flashing 4 0r 5 times then go's out. This has only started happening. I changed the oil & filter and also went through the sequnce to turn the service light off. Amber light still flashing. Only happens when engine is cold not when it has been run for a few seconds.

Was this
answer
helpful?
Yes
No
Wednesday, May 24th, 2017 AT 1:25 PM
Tiny
RASMATAZ
  • MEMBER
  • MERGED

Check the oil pressure with a mechanical gauge if its within specs-could be the oil pressure switch acting up

Was this
answer
helpful?
Yes
No
Wednesday, May 24th, 2017 AT 1:25 PM
Tiny
SPARKYB
  • 2004 VOLKSWAGEN POLO
  • MERGED

Engine Mechanical problem
2004 Volkswagen Polo 4 cyl Two Wheel Drive Manual 40000 miles

My car was serviced 1 year ago during which I have done about 2,000 miles. The oil warning light has come on. Should I just top up the oil level or should I take it to the VW dealer for a checkup?

Was this
answer
helpful?
Yes
No
Wednesday, May 24th, 2017 AT 1:25 PM
Tiny
RASMATAZ
  • MEMBER
  • MERGED

1st check the oil level if okay -if you wish use a mechanical gauge hook it up where the oil pressure switch is -you have to remove the switch then install the gauge and start the car up and read the pressure if normal replace the oil pressure switch abnormal could mean oil pump and engine bearings.

Was this
answer
helpful?
Yes
No
Wednesday, May 24th, 2017 AT 1:25 PM
Tiny
CALBI
  • 2004 VOLKSWAGEN POLO
  • 187,369 MILES
  • MERGED

2 days ago my polo red oil lamp starts flickering repeatedly. I did serviced a month ago and had the car reset. There's also a white liqiud on the dipstick its not water what can it be? Espesialy when the car is cold! Plz hlp

Was this
answer
helpful?
Yes
No
Wednesday, May 24th, 2017 AT 1:26 PM
Tiny
DOCFIXIT
  • EXPERT
  • 19,023 POSTS
  • MERGED

White liquid would be coolant is it on bottom of stick?

Was this
answer
helpful?
Yes
No
Please consider a donation if we helped you
Wednesday, May 24th, 2017 AT 1:26 PM
Tiny
CRIMLEY
  • 1999 VOLKSWAGEN POLO
  • 185,000 MILES
  • MERGED

A new fan was fitted (after market part) it damaged the radiator the engine over heated the gauge didnt come up. After 2hour of driving I stop. When I started the car it made a havy grinding, knocking sound. Smoke came out of the oil fill cap when I removed it. The car was parked for 9 days and was starting fine and sound is gone. I fitted a new radiator and fan (from agents) now the only problem is the oil light. When I switch the ignition on the oil light flickers untill I start the car then it goes off. Polo playa 1.6i 1999 Please help its worrying me. Have drove the car only around the block so far at 80km/h and running good.

Was this
answer
helpful?
Yes
No
Wednesday, May 24th, 2017 AT 1:26 PM

Please login or register to post a reply.

Related Oil Light Questions

Recommended articles