No power to instrument panel or ignition

Tiny
DON JOHNSON2
  • MEMBER
  • 1994 GMC SIERRA
  • 5.7L
  • V8
  • 4WD
  • MANUAL
  • 190,000 MILES
I have no power to the instrument panel or ignition. I replaced the ignition switch but that did not work. I have power to the headlights, interior lights and horn. Any help would be great!
Do you
have the same problem?
Yes
No
Wednesday, March 8th, 2017 AT 1:53 PM

1 Reply

Tiny
STEVE W.
  • EXPERT
Sounds like a bad fusible link. Do the hazard flashers work? If they do not work as well, look at the battery junction block on the firewall. There will be five to six fusible links bolted to it.

If you have four wheel ABS, three of them should be black. One of those is bad. One feeds the four wheel anti lock system, one feeds the interior lights, horn and headlights, the last feeds the ignition switch.

To make it a bit easier, remove all of the links, clean them, reinstall the two gray and the rust colored ones. Now turn on the headlights and connect the black ones one at a time until the headlights come on. That leaves you with one or two black links. If you do not have four wheel ABS the remaining black link is bad. You will need to dig it out of the harness and see if it is burnt or if it is just a bad connector or splice. If you do have four wheel ABS and have two remaining links. Use a test light connected to ground to probe the large red feed wire on the ABS module that will be on the brake master cylinder. Now touch the links one at a time to the power post. One should light the light. That is the ABS feed, the other is the bad fuse link.

If it is burnt you have a short in that part of the system.
Was this
answer
helpful?
Yes
No
Wednesday, March 8th, 2017 AT 3:33 PM

Please login or register to post a reply.

Recommended Guides