1994 Nissan Altima engine won't run above idle

  • 1 POST

Engine Performance problem
1994 Nissan Altima 4 cyl Front Wheel Drive Automatic

engine starts, slow idle about 600 rpm. Won't rev up, stalls as soon as throttle moves. Timing seems OK, new plugs, plug wires, distributor cap and rotor. Mass Air Flow sensor checks OK according to Chilton manual, as does Throttle Pos Sensor. About 5000km since replacement of fuel pump and filters. Air filter looks good

Do you
have the same problem?
Friday, June 27th, 2008 AT 12:16 AM

1 Reply

  • 15 POSTS

Try this, get some starting fluid, spray above filter in airbox, if it starts like normal and then stalls again they you definitely have the below issues, it affects altimas from 93 to 2002.
Hi, I have had a similar issue, took the car to a shop they replaced a bunch of parts that they said were definitely bad, but thats another story, they gave me a BS story each time they replaced something, and I am talking a reputible shop in town here, not some joe shmo, found the issue myself after doing some thinking, if you cannot start car, have someone else turn key for you and you listen from backseat with the larger half of the seat folded forward, the fuel pump is right below where the velcro connects the trunk carpet right below there, but to get to it back seat comes out, along with the round pressed metal surround under the plastic pieces there along with them. Anyways listen for the fuel pump as the other person turns key, you cant do this test yourself. If you hear nothing, its most likely it, try a few times, then get out and rock the car back and forth a couple times from side to side, at this point the wire which is half broken inside may align itself, try listening again, if you are able to start car, then get the sending unit or fuel pump harness kit, forget which it was, but the wire that is bad is the one that connects to top of the fuel tank seal and the other side to the fuel pump. I hope this saves a lot of headaches for everyone, and I can't believe that nissan doesnt even have this documented. Definite design flw, basically what happens is while driving the sending unit along with fuel pump are suspended by 2 fuel lines and this wire harness, and it, just like any piece of metal eventually partially breaks when folded back and forth a thousand times.I dont believe you can buy the cable itself, it comes as a part of the kit or sending unit, one connector is flat, other square with rounded corners, I believe around 80$ bucks at nissan dealer only. Good luck, let me know how it works out.

Was this
Monday, July 7th, 2008 AT 10:47 PM

Please login or register to post a reply.

Recommended Guides