Mitsubishi Eclipse stalling/Rough Idle

Tiny
SKYLERGLIDE88
  • MEMBER
  • 2003 MITSUBISHI ECLIPSE
  • 95,000 MILES
2003 Mitsubish Eclpise idle/stall?
I have a 2003 Mit Eclipse RS. Automatic. 90K miles. 2.4L 16 Valve. Car started stalling during deceleration and stop signs. Only would happen while foot not on accelerator. Took to my mechanic. Got 2 Codes. Misfire and Bad O2 Sensor.
Mechanic suggested follow the misfire. Replaced all plugs, electrical box, wires, tune up, oil change $360 later did same thing. Next got second opinion. This mechanic cleaned throttle body and IAC. $120 dollars later same problem. Finally, took to Mitsubishi. They suggested always follow the computer and replace O2 Sensor. $175 later still idles poor. Feels like gonna stall but doesn't. Don't know what to do or where to take next. Thats 3 mechanics NO ROOT cause. Everyone treating symptoms not some tricky cause. Read that only other cause could be small hose that you can only tell is bad when its opened up but seems like long shot.
Anyone have/fixed problem like this please let me know.
(Since 02 sensor change runs better untill A/C turned on
and SES light has come back on)
Please help!
Thanks, Sky

Other Info- 6 months ago- Replaced radiator, therm, all belts $725
4 months ago New battery and housing

Do you
have the same problem?
Yes
No
Sunday, April 28th, 2013 AT 9:33 AM

1 Reply

Tiny
ASEMASTER6371
  • EXPERT
What are the exact codes?

Roy
Was this
answer
helpful?
Yes
No
Sunday, April 28th, 2013 AT 9:55 AM

Please login or register to post a reply.

Recommended Guides