1991 Mercury Marquis Fuel guage not working

Tiny
LWA
  • MEMBER
  • 1991 MERCURY MARQUIS
  • V8
  • 2WD
  • AUTOMATIC
  • 120,000 MILES
I Replaced the in-tank fuel pump about 1 yr ago. Fuel Guage was reading ok for awhile. Had to drain some bad gas out of tank before replacing pump. Not sure we got it all out. Fuel gauge was working for a brief period. The Auto is a back up and used occasionally. With the key off, guage shows slightly below full every time. When key is turned on the guage goes beyond full mark and goes out of site. It never goes down to the empty side even after you have burned some fuel and turned off ignition. Also "check engine" lite comes on/off sporatically. When it does the auto seems to buck for a quick second and sometimes stalls when idling. Can this be a fuel pump problem indicator? Whats your best thoughts as to what it might be causing it to stay on the full side. I had it changed out by a repair shop. Is their a chance the sensor or float or whatever is not working, or grounded. How can I trouble shoot it myself to avoid dropping out the tank, if the pumps the real problem? TKS Larry
Do you
have the same problem?
Yes
No
Wednesday, February 6th, 2008 AT 4:52 PM

1 Reply

Tiny
2CARPROS MIKE
  • ADMIN
When you replace the fuel pump always use an OEM (Original Equipment Manufacturer) unit. Have your fuel pressure checked to make sure the new fuel pump is working properly. Have your computer scanned for trouble codes, the runability problem could be as simple as a tune-up.
Regarding the gauge, it sounds like your sending unit is bad. If the sending unit was replaced with the fuel pump then the gauge is bad.
Was this
answer
helpful?
Yes
No
Thursday, February 7th, 2008 AT 11:41 AM

Please login or register to post a reply.

Recommended Guides