CHECK ENGINE LIGHT COMING ON

1999 Mazda Protege

Tiny

Jordoe28

August, 15, 2008 AT 10:24 AM

Engine Mechanical problem
1999 Mazda Protege Front Wheel Drive Automatic 172119 miles

About 2 months ago I purchased a used Mazda Protege from a family friend. She had everything on it safetied and brought the car into Mazda for an engine test where they said everything was in really good condition. About a month after having it, the Check engine light came on while I was driving. Just to make sure, we unplugged the battery so it would reset, the light went away, but came on again in about 2 weeks. The car sounds great, starts great, all the fluids have been checked and double checked, the filters were just replaced before I bought it so is this just a sensor problem or should I be spending the money to take it in and get it checked?

FOUND 17085 RELATED QUESTIONS

11 Answers

Tiny

blackop555

August, 15, 2008 AT 12:20 PM

Take it to autozone, have the code scanned and get back to me.

Autozone will scan for free!

Post the code, not what the code means.

Tiny

Jordoe28

August, 15, 2008 AT 12:23 PM

I would but I live in Canada and we don't have an autozone here.

I will call around and see if I can find a place to scan for free and get back to you. Thanks

Tiny

xowey

August, 22, 2008 AT 9:05 PM

You can also start by performing a quick visual inspection, look to make sure that no connectors are disconnected under the hood, also make sure that the gas cap is tight and the sealing surface is clean. Let us know how it's going eh.

Tiny

Jordoe28

August, 23, 2008 AT 1:53 AM

Well so far, since unplugging the battery and reseting everything, the engine light has not come back on. I started a Trip to record my mileage this time and so far I've driven 379 miles. However when it does come back on, like it did the previous times I resetted, I will take it in and get back to you guys. Thanks

Tiny

blackop555

August, 24, 2008 AT 6:33 PM

Doesnt sound too major in that case as it should be coming back on right away, when ever its your convinence I would take and have it looked at, just in case.

Tiny

Jordoe28

August, 27, 2008 AT 2:31 PM

I am now at 600 miles and the Check Engine still has not come on after I reset it. Today I did however go to Mr. Lube to get an oil change. They also check everything and the only thing that they noticed was my PCV Emission valve was really plugged. So they replaced it for 12 dollars.

Could it of been the PCV valve being plugged causing the engine light to come on?

Tiny

blackop555

August, 27, 2008 AT 3:33 PM

Yes that can cause the problem! It can cause the fuel mixture to show as lean or rich. And can also mess with the idle!

Tiny

Jordoe28

August, 27, 2008 AT 4:04 PM

Thank you! That is good to hear and I hope that is what was happening.

Tiny

blackop555

August, 27, 2008 AT 5:03 PM

I wish you luck.

Tiny

Jordoe28

September, 1, 2008 AT 12:32 PM

Alright so at 1093 miles, the Check Engine light has finally returned. I guess I will bring it in to get it checked out.

Please login or register to post a reply.

Code Read Retrieval/Clear Mercedes-Benz C230
How to gather codes Ford Explorer
Code Read Retrieval/Clear Chevrolet Camaro
Code Read Retrieval/Clear Scion XD
 Step by Step video GMC Yukon XL 2000-2006
Code Read Retrieval/Clear Mercedes Benz
How to read codes Chevrolet Blazer