1992 Mazda B2200 starts but then stalls

Tiny
MAZDA MUFF
  • MEMBER
  • 1992 MAZDA B2200
  • 4 CYL
  • 2WD
  • MANUAL
  • 174,000 MILES
My mazda one day started to sputter and then stall. I changed the fuel filter and then it ran fine for a month or so. The problem started again. I replaced the fuel filter again but the problem persists. The engind will start and run for about 30 seconds then stall. Any idea as to what it could be?
Do you
have the same problem?
Yes
No
Wednesday, August 19th, 2009 AT 1:44 PM

9 Replies

Tiny
RASMATAZ
  • MEMBER
Fuel pump could be failing check the fuel pressure if its within specs-start here
Was this
answer
helpful?
Yes
No
+2
Wednesday, February 29th, 2012 AT 10:40 PM
Tiny
DOUGB2200
  • MEMBER
I have the same vehicle same problem. Fuel supply is ok. In the last week the engine has shut down then refired 3 times at hiway speeds. Today, start and stop run time 3 seconds
Was this
answer
helpful?
Yes
No
Thursday, March 1st, 2012 AT 1:25 AM
Tiny
RIVERMIKERAT
  • MEMBER
Dougb2200, how do you know fuel supply is Ok? Did you disconnect the fuel line and crank the engine over? Or did you put a fuel pressure gauge on it?

Also check the coil. It could be failing when getting hot.
Was this
answer
helpful?
Yes
No
Friday, March 2nd, 2012 AT 5:27 AM
Tiny
DOUGB2200
  • MEMBER
Fuel pressure is37 lbs. I am chasing maf sensor, when I disconnect sensor, engine will start and run. Plug it back in engine dies thanks rivermikerat for your input doug
Was this
answer
helpful?
Yes
No
Friday, March 2nd, 2012 AT 11:19 PM
Tiny
RIVERMIKERAT
  • MEMBER
Sounds like the sensor is very bad.
Was this
answer
helpful?
Yes
No
Friday, March 2nd, 2012 AT 11:51 PM
Tiny
DOUGB2200
  • MEMBER
Have a sensor off of a running b2200 coming, I will update results
Was this
answer
helpful?
Yes
No
Sunday, March 4th, 2012 AT 6:48 PM
Tiny
RIVERMIKERAT
  • MEMBER
Ok.
Was this
answer
helpful?
Yes
No
Monday, March 5th, 2012 AT 4:29 AM
Tiny
DOUGB2200
  • MEMBER
I changed amf sensor no difference, found a mechanic turns out b2200 was his intro to auto repairs so he was interested. After an hour of testing. He felt confused that he could not get check engine light code. The ecm, located passenger kick panel, looked rusted, he had used one, plugged it in, fixed it. Runs good now
Was this
answer
helpful?
Yes
No
+1
Monday, March 12th, 2012 AT 7:15 PM
Tiny
RIVERMIKERAT
  • MEMBER
Cool glad to hear it's up and running well again. Thanks for using 2carpros. Com. Please tell your friends about us.

Closing thread completed.
Was this
answer
helpful?
Yes
No
+1
Monday, March 12th, 2012 AT 8:34 PM

Please login or register to post a reply.

Recommended Guides