2005 Kia Optima mis fire

  • 2 POSTS
  • 2005 KIA OPTIMA

Engine Performance problem
2005 Kia Optima 4 cyl Front Wheel Drive Automatic 87000 miles

my 2005 optima is consistently codeing misfire on cylinder 2 I have already changed the spark plugs and what not and there is no change. It doesnt always mifire but almost always when I am accelerating from a stop and it does it much worse if my ac is running. Turning the ac of sometimes fells like I am turning on a turbo or something be cause as soon as its of if I am alreday moving often the car will accelerate normally. I have thought that maybe its a faulty fuel injector or fuel injector wire but I am not sure. I know its not the spark plug wires because the way the engine is set up the spark plugs are on top of the engine and there are two small coil pack looking things. One supplies the charge for spark in cylinders 1 and 2 and the other 3 and 4. Boots for 2 and 4 are actually conneted directly to the coil pack and I am assumeing that the coil pack isnt broken in any way because I would think that if it were that it would misfire on both cylinders 1 and 2. Which leaves me once again with the fuel injectors. Honestly I dont know I am a logical thinker and going of what I can see I am making assumptions your the expert can you help me?

Do you
have the same problem?
Wednesday, September 22nd, 2010 AT 1:43 PM

1 Reply

  • 77,150 POSTS

Check compression and fuel injector on #2 cylinder.

Was this
Wednesday, September 22nd, 2010 AT 4:45 PM

Please login or register to post a reply.

Recommended Guides