IT HAS NO MOVE MENT AT

2000 Ford Ranger

Tiny

kamsasmeadows07

February, 15, 2014 AT 2:16 PM

I was driving at 70mph all of. Sudden it felt like u pushed in a clutch but its an automatic. It will not move at all

I have it on jack stands and there is no move ment on the drive shaft when in drive, reverse, o/d, 2, 1

4 Answers

Tiny

homer1967

February, 15, 2014 AT 3:44 PM

Have you checked the transmission fluid level?Do you see any signs of leakage under the vehicle or spots where you park it?It sounds like it is low on fluid, but unfortunately it may be to late, after the pump runs dry for a while it can burn up. But maybe you will get lucky. First check it with the truck off to avoid doing further damage. Once you get the level up to the full mark, by adding fluid to it then start it and re-check the fluid level and get it up to the full mark. It should tell you on the dipstick what fluid it requires.

Tiny

kamsasmeadows07

February, 15, 2014 AT 5:01 PM

So I have droped my tranny pan changed filter fluid look good nothing in it. Nice and clean no out put from tranny still nothing no leaks at all

Tiny

homer1967

February, 15, 2014 AT 6:17 PM

That sucks, it sounds like the pump went bad in the tranny. The only way to be sure would be to test the line pressure, which requires very specific equipment.

Tiny

kamsasmeadows07

February, 16, 2014 AT 9:55 AM

And there are codes now C1155, C1102, B1318

Please login or register to post a reply.

Drive Shaft Removal - All Cars
Replace Drive Shaft U-Joint Like a Pro
Axle Bearing, Seal, E-Brake Shoes, Brake Pads
Transmission Service Ford Super Duty F-250
CV Axle Replacement