Instrument cluster and anti theft module

Tiny
SIGNSANDDESIGNS
  • 2002 FORD F-150
  • 100,000 MILES

Having same problem as audi 08r8. Truck starts, as soon as I shut it off it does not start again. All instruments sweep as soon as it does start. When it is not going to start, no sweeping. When it does start all instruments light up and work fine. Dealer tells me I need new Cluster and module, at the tune of over $700.00. If the instrument cluster is lighting and working can I just change the module?












$

Do you
have the same problem?
Yes
No
Thursday, August 29th, 2013 AT 10:00 PM

3 Replies

Tiny
HMAC300
  • EXPERT
  • 45,785 POSTS

Scan for codes and check fuel pressure first with a gauge

Was this
answer
helpful?
Yes
No
Friday, August 30th, 2013 AT 6:46 AM
Tiny
SIGNSANDDESIGNS
  • MEMBER

Codes check and fuel pump replaced by same dealer. They said there was no fuel pressure. ( If anti theft module is bad would there be any fuel pressure! ) I realize it has been too long a time to complain now, but I had the same problem right after the fuel pump was replaced. And I still have the same problem today. Can I replace the module or do I have to replace the instrument panel too? If I can find out more info I will take the truck to someone who will fix this, unless I can replace the part myself.

Was this
answer
helpful?
Yes
No
Friday, August 30th, 2013 AT 12:32 PM
Tiny
HMAC300
  • EXPERT
  • 45,785 POSTS

Modules are vin specific and have to be programmed. Yo have an inertia switch on rh side of dash that couldbe screwing up or just a plain bad connection at fuse box as well. The anti theft could be reprogrammed if that is the problem. Check your ground on engine and battery to body. For fuel pump it'son rh head on a 4.6L you could have a bad dash as well

Was this
answer
helpful?
Yes
No
Friday, August 30th, 2013 AT 12:39 PM

Please login or register to post a reply.

Other Security Computer Replace/Remove Questions