1990 Honda Civic loss of power

Tiny
MJ65
  • MEMBER
  • 1990 HONDA CIVIC
  • 4 CYL
  • AWD
  • MANUAL
  • 225,000 MILES
This car runs perfect on plane but, when going up a hill I lose power. I was told to change fuel filter and I did change the one on the firewall but I think there is another one along frame or in rear well but I can't find one. Is there another one and is this the source of my problem?
Do you
have the same problem?
Yes
No
Thursday, May 27th, 2010 AT 6:38 PM

2 Replies

Tiny
RASMATAZ
  • MEMBER
Hi mj65, Welcome to 2carpros and TY for the donation

The following can contribute to your problem

Oxygen sensor.
Xx Catalytic converter xx do this 1st
Fuel injectors dirty/sticking.
Mass airflow sensor/Airflow meter.
Throttle position sensor.
Manifold absolute pressure sensor.
EGR Valve
Fuel pressure regulator leaking or defective fuel pump.
False air leakage.
Fuel contamination.
Foul/defective spark plugs.
Open spark plug wires.
Ignition coil/Coil packs defective.
Incorrect ignition timing.
Cap and rotor.

Note:If it doesn't apply disregard.
Was this
answer
helpful?
Yes
No
Thursday, May 27th, 2010 AT 7:55 PM
Tiny
MJ65
  • MEMBER
Yeah I've already replaced the coil, cap, rotor, dist, wires, o2 sensor, muffler, and between you and me.I cut out the converter and ran it straight. Could it be it's just has 87 hp and doesn't has the balls to climb up these steep hills in the rockies? I mean I'm almost in 2nd gear 3rd barely 20 to 25 mph but on plane it'll run 80 mph no sweat. Like a sewing machine. Your first guess? I'm at a loss here. I'm thinking. Losing pressure somehow somewhere, I dont seeing it being spark? It's gotta be fuel cause I still have the same problems after wards. Ghost in the machine maybe. Damn gremlin or what lol? I guess I could left up the pass. Mat and run another diagnostic?
Was this
answer
helpful?
Yes
No
Thursday, May 27th, 2010 AT 10:56 PM

Please login or register to post a reply.

Recommended Guides