1995 GMC Jimmy 95 Jimmy no fuel pressure

Tiny
JIMMY95
  • MEMBER
  • 1995 GMC JIMMY
  • 6 CYL
  • 4WD
  • AUTOMATIC
  • 171,000 MILES
Ok I was driving on the higjway, so the trucks just shut off, towed back home, so no fuel pressure at all, I replaced the relay, nothing, put a new fuel pump, nothing, no pressure, fuel pump just wont kick on, I use a hot wire to power the fuel pump in the harness right there on the top of the fuel tank, but nothing, a faulty sending unit can be possible, dont let power the fuel pump? Do this truck has a shut off valve or switch, thanks.
Do you
have the same problem?
Yes
No
Tuesday, August 4th, 2009 AT 8:13 PM

9 Replies

Tiny
RASMATAZ
  • MEMBER
Power the fuel pump connector gray wire from the battery positive post did it come on if not check the black ground wire to it. If okay think! Fuel pump again
Was this
answer
helpful?
Yes
No
Tuesday, August 4th, 2009 AT 8:26 PM
Tiny
JIMMY95
  • MEMBER
I tested the old fuel pump, I power it and it works! That means the fuel pump wasnt the problem.
Was this
answer
helpful?
Yes
No
Tuesday, August 4th, 2009 AT 8:29 PM
Tiny
RASMATAZ
  • MEMBER
Where are you checking the fuel pressure? Is this the spider Vortec fuel system come on back
Was this
answer
helpful?
Yes
No
+1
Tuesday, August 4th, 2009 AT 8:30 PM
Tiny
JIMMY95
  • MEMBER
It say vortex, but is not the spider one, this is a 95, I put my gauge at the fuel rail, pump is not kicking on at any time, check the fuse, but is ok, I put a new fuel pump relay, fuel filter was replaced a month ago, I didnt check the black ground wire, I put the hot wire in the middle of the harness at the fuel tank and sparks! I put the new fuel pump, with the new inside harness, can the sending unit be shorted?
Was this
answer
helpful?
Yes
No
Tuesday, August 4th, 2009 AT 8:36 PM
Tiny
RASMATAZ
  • MEMBER
The gray wire powers the fuel pump-Sparks you shorted something out could be the pump or the sending unit.
Was this
answer
helpful?
Yes
No
Tuesday, August 4th, 2009 AT 8:39 PM
Tiny
JIMMY95
  • MEMBER
Well I put the new fuel pump and hook up every thing, I turn the key on, and nothing, then I did that with the hot wire, I will check it tomorrow, if smthg happen I will let you know of course I will not forgot about the donation thanks for your time.
Was this
answer
helpful?
Yes
No
Tuesday, August 4th, 2009 AT 8:47 PM
Tiny
RASMATAZ
  • MEMBER
Check if the ECM/BATT fuse no.9 20amp is blown, this the one that powers the fuel pump relay and then transfer power thru the gray wire to the fuel pump.
Was this
answer
helpful?
Yes
No
Tuesday, August 4th, 2009 AT 8:55 PM
Tiny
JIMMY95
  • MEMBER
I did that before installing the new fuel pump. Is kind of weird, I hate this kind of problems, is not usual.
Was this
answer
helpful?
Yes
No
Tuesday, August 4th, 2009 AT 9:10 PM
Tiny
RASMATAZ
  • MEMBER
The old pump works but new pump don't think! For a moment here-When you hook up the new fuel pump there were sparks! You probably fried it-put the old one on-did it come on.

The fuel pump relay powers the pump for 2 secs to prime the system when it fires up the fuel pump and oil sending unit powers it from there.
Was this
answer
helpful?
Yes
No
Tuesday, August 4th, 2009 AT 9:31 PM

Please login or register to post a reply.

Recommended Guides