2002 GMC Envoy

Tiny
DEBSCAR
  • MEMBER
  • 2002 GMC ENVOY
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 72,000 MILES
Sometimes when I start the car, the abs and brake light are on and the a/c-heater fan won't work. After turning the car off and on again (sometimes it takes a few times) everything works.
Any ideas?
Do you
have the same problem?
Yes
No
Monday, December 29th, 2008 AT 5:42 PM

2 Replies

Tiny
BRIAN 1
  • MEMBER
Here is a bulletin for this problem, Vehicle may exhibit a combination or all of the following symptoms: ABS light on, Red BRAKE light on, Service 4WD light on, HVAC blower motor inoperative. Various DTCs may also be present. Diagnose for loss of battery voltage to the rear fuse block on circuit 300 ORN for the following fuses:

Note: Prior to proceeding forward with the information below, it is important to verify the voltage as indicated however it is equally important to verify the integrity of each circuit. This can be achieved by performing a voltage drop test or by adding a device to each circuit that will supply sufficient load to verify the circuits integrity.

HVAC 30A, 4WD 15A, HVAC 1 10A, BRAKE 10A, TBC RUN 3A.

Check circuit 300 ORN for battery voltage when the ignition key is in the RUN position.
Check for battery voltage at the rear fuse block under the rear seat Connector C1 pin D9.
If battery voltage IS NOT present at these locations, check for voltage at the ignition switch pin G for circuit 300 ORN.
If battery voltage IS present at the ignition switch pin G, check circuit 300 for an open.
If battery voltage IS NOT present at the ignition switch pin G, replace the ignition switch.
Post back with what you find
Was this
answer
helpful?
Yes
No
Monday, December 29th, 2008 AT 5:47 PM
Tiny
PHIL RODRIGUEZ
  • MEMBER
  • 2003 GMC ENVOY
  • 4.3L
  • 4WD
  • AUTOMATIC
  • 229,000 MILES
Truck was parked due to fuel pump leak for about three months. Ran fine when parked, replaced fuel pump, then truck started with electrical problems, and ran rough. Passenger side turn signal and passenger side brake light would stay on, disconnected battery and then reconnect, lights would stay off for a while then would come back on. Please help me. Thank you.
Was this
answer
helpful?
Yes
No
Thursday, November 2nd, 2017 AT 10:33 AM (Merged)

Please login or register to post a reply.

Recommended Guides