1993 Ford F-150 engine running problem

Tiny
ERNIE98
  • MEMBER
  • 1993 FORD F-150
  • V8
  • 4WD
  • AUTOMATIC
  • 191,000 MILES
Ihave a 93 f150 with a 5.8 in it and I have a problem with it when you get it on a load it runs lean and starts run bad temp starts rising I replaced comp, map, injectors, fuel reg, one way vavles on the tanks, fuel filter, tps, plugs, wires, coil, had ingtion module check, I ran it with the scanner on it and when it does it my timing retards its self down to 12 degrees and im running out of options anybody know anything else to try
Do you
have the same problem?
Yes
No
Wednesday, November 10th, 2010 AT 7:03 AM

5 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Have you checked for vacuum leaks? Also, have you checked the knock sensor? (You do mean 12 BTDC, correct?)
Was this
answer
helpful?
Yes
No
Wednesday, November 10th, 2010 AT 7:16 AM
Tiny
ERNIE98
  • MEMBER
I tried unpluging the knock sensor and that didnt change any thing I also checked fuel pessure and it is good
Was this
answer
helpful?
Yes
No
Wednesday, November 10th, 2010 AT 8:13 AM
Tiny
ERNIE98
  • MEMBER
I put a vacuum gauge on and the vacuum is good
Was this
answer
helpful?
Yes
No
Wednesday, November 10th, 2010 AT 8:15 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Have you checked the crank sensor?
Was this
answer
helpful?
Yes
No
Wednesday, November 10th, 2010 AT 3:42 PM
Tiny
ERNIE98
  • MEMBER
Its a 93 it dont have a crank sensor does it it has a pickup sensor in the distibritor is that what your talking about?
Was this
answer
helpful?
Yes
No
Thursday, November 11th, 2010 AT 6:52 AM

Please login or register to post a reply.

Recommended Guides