1990 Ford F-150 wiring

Tiny
FORD MAN CHRIS
  • MEMBER
  • 1990 FORD F-150
Electrical problem
1990 Ford F150 6 cyl Two Wheel Drive Manual

My fuel pump runs, my ignition is sparking, but it seems as though the injectors aren't working once I crank the engine. I can hear them click, when I first turn my toggle switch on, and when I first crank it it hits like it wants to start, but won't unless I turn the switch off and back on, and it just hits again but won't start. New fuel filter, distributor, coil, stator, plug wires, and fuel pump, also O2 sensor. Ignition system completely redone, and mostly all new fuel system, except injectors, and computer.
Do you
have the same problem?
Yes
No
Monday, March 15th, 2010 AT 9:29 PM

14 Replies

Tiny
RASMATAZ
  • MEMBER
Verify your fuel pressure with a gauge if its within specs and get back with the readings we start here.
Was this
answer
helpful?
Yes
No
Monday, March 15th, 2010 AT 9:44 PM
Tiny
FORD MAN CHRIS
  • MEMBER
My fuel common rail psi is 45-50
Was this
answer
helpful?
Yes
No
Monday, March 15th, 2010 AT 10:07 PM
Tiny
RASMATAZ
  • MEMBER
What liter engine? 4.9 5.0 5.8?

Is this KOEO or KOER readings?
Was this
answer
helpful?
Yes
No
Tuesday, March 16th, 2010 AT 1:50 AM
Tiny
FORD MAN CHRIS
  • MEMBER
My engine is a 4.9L inline 6 also known as a 300-6
Was this
answer
helpful?
Yes
No
Tuesday, March 16th, 2010 AT 1:05 PM
Tiny
RASMATAZ
  • MEMBER
Key On Engine Off 50 - 60 psi
Key On Engine Running 45 - 60 psi
Was this
answer
helpful?
Yes
No
Tuesday, March 16th, 2010 AT 1:47 PM
Tiny
FORD MAN CHRIS
  • MEMBER
Fuel pressure has been verified, except for with the engine running because the engine won't start. I'm trying to find out what else could possibly make the engine not run. It seems as though the injectors aren't getting a pulse signal, and I need to know what to check for that.
Was this
answer
helpful?
Yes
No
Tuesday, March 16th, 2010 AT 4:17 PM
Tiny
RASMATAZ
  • MEMBER
Hook up a noid lite at the injector/s harness connector it should be flashing if the circuit is good if it does-its coming from the injector/s
Was this
answer
helpful?
Yes
No
Tuesday, March 16th, 2010 AT 5:34 PM
Tiny
FORD MAN CHRIS
  • MEMBER
I'll try it, and let you know. Thanks
Was this
answer
helpful?
Yes
No
Tuesday, March 16th, 2010 AT 8:09 PM
Tiny
FORD MAN CHRIS
  • MEMBER
I put a noid light on the injector plug in, and both sides of the plug make the light come on but not flash, this was done with the engine being cranked, but not running.(Since it won't start).
Was this
answer
helpful?
Yes
No
Friday, March 19th, 2010 AT 9:32 PM
Tiny
RASMATAZ
  • MEMBER
The injectors ground drivers of the computer went south-it should be flashing if the ground drivers are good
Was this
answer
helpful?
Yes
No
Friday, March 19th, 2010 AT 11:39 PM
Tiny
FORD MAN CHRIS
  • MEMBER
So does that mean I need a new computer, or could it be a short somewhere in the wiring?
Was this
answer
helpful?
Yes
No
Friday, March 19th, 2010 AT 11:40 PM
Tiny
RASMATAZ
  • MEMBER
If you test the wiring and they all good replace the computer
Was this
answer
helpful?
Yes
No
Saturday, March 20th, 2010 AT 12:04 AM
Tiny
FORD MAN CHRIS
  • MEMBER
Okay, I'll try that. Thank you.
Was this
answer
helpful?
Yes
No
Saturday, March 20th, 2010 AT 10:32 PM
Tiny
FORD MAN CHRIS
  • MEMBER
Okay, I got the other problem fixed. Finally!

I got a new problem though, there is a really foul smell in my vent system, and around the truck, kinda smells like dead rat, it's really bad when I turn the dash blower on. No vibration in the fan, just a foul smell !
I would like to know what I need to do to get the culprit out before it gets really nasty. This smell is really bad. Please, help.
Was this
answer
helpful?
Yes
No
Wednesday, March 24th, 2010 AT 12:25 AM

Please login or register to post a reply.

Recommended Guides