2002 Ford Explorer 4X4 battery light & will not go into

Tiny
JCBOGIE65
  • MEMBER
  • 2002 FORD EXPLORER
I had to replace my alternator about a month ago. Ever since then the battery light stays lit but it is holding a charge. Anyone know why that is staying on.

Also, we had our first snow and driving to work my tires spun but the 4wd never kicked in. It has the electronic 4wd with the buttons on the dash. I tried to put it in 4w high but it never engaged.

Any help would be greatly appreciated.

Thanks
Do you
have the same problem?
Yes
No
Saturday, December 9th, 2006 AT 1:32 PM

3 Replies

Tiny
J_MOORE
  • MEMBER
I am also having this problem, I replaced my axle and the sound went away mostly but a few months of driving later and it feels like the sound is coming back. So it might be the CV joint that is ruining the axle.
Was this
answer
helpful?
Yes
No
Saturday, September 23rd, 2006 AT 8:40 PM
Tiny
CARUNDELL
  • MEMBER
Hey jc,
Check the connection (field wire) at the alternator (usually a single wire plug) clean it good, your light should go out.

A common problem with that trucks 4x4 is the automatic transfer case motor. Be sure to check the applicable fuses before you go for the motor!

Regards,

Chris
Was this
answer
helpful?
Yes
No
Saturday, December 9th, 2006 AT 2:58 PM
Tiny
JCBOGIE65
  • MEMBER
Hey jc,
Check the connection (field wire) at the alternator (usually a single wire plug) clean it good, your light should go out.

A common problem with that trucks 4x4 is the automatic transfer case motor. Be sure to check the applicable fuses before you go for the motor!

Regards,

Chris[/quote:2e24234759]

Hey Chris

Thanks for the response. I check the fuses in the truck and the fuse under the hood, all are fine. If the motor was out would the look on the instrument panel still light up? Mine doesn't.

Thanks again

John
Was this
answer
helpful?
Yes
No
Saturday, December 9th, 2006 AT 3:16 PM

Please login or register to post a reply.

Recommended Guides