5.4L : IDLES ROUGH, JERKS WHEN EXCELERATING

1999 Ford Expedition

Tiny

mamacass

August, 19, 2007 AT 4:42 PM

I have a '99 ford expedition with the 5.4 V8 with 101,000 miles and have it's oil changed regularly. It is idling really rough and kind of jerks when I'm driving and excelerating and the service engine soon light came on. It almost acts like I got some bad gas but haven't put any gas in it for a week. It ran fine until today. I get in and start it and I knew instantly that something was wrong. I just moved to a new town and don't have a mechanic I can trust yet and I would greatly appreciate any help in narrowing down what the possible problem might be. My husband is in the military and not here to help me! I just don't want to get ripped off by some greedy mechanic looking to take advantage of me. I would love to have at least an idea of the possible problem and not go into a shop blind. I don't mean to offend anyone but I have been ripped off before, so I've become a little jaded towards some repair shops.

FOUND 4236 RELATED QUESTIONS

Running Rough

27 ANSWERS
34 IMAGES

Idles Rough/changed Ects

37 ANSWERS
3 IMAGES

1 Answer

Tiny

mjs52681

November, 26, 2007 AT 6:58 PM

Did you ever get it fixed. It sounds like it could be one of your spark plugs.

Please login or register to post a reply.

Code Read Retrieval/Clear Scion XD
 Step by Step video GMC Yukon XL 2000-2006
Code Read Retrieval/Clear Chevrolet Camaro
How to gather codes Ford Explorer
Read Codes Like a Pro