1994 Ford Escort (Ideling Issues)

Tiny
NATHANKEEP
  • MEMBER
  • 1994 FORD ESCORT
My current problem with my '94 ford escort, is that upon starting the car up in the morning(s). Though this issue isnt present while in park or Neutral (only when in Drive). It idels really funny (shakes and sounds like it wants to die). I had ran a diagnostic test on it about a year ago to see if anything could possibly be wrong, and it turned out that an EGO Sensor, as well as a Shift Solenoid 3 circuit failure was detected. Now, I have no idea if either of these could possibly be related to this current problem. Or it is really something much worse. I have no been hearing any knocking noise which might indicate a cracked piston, but the thought is still there. Also, the idel problem really only seems to be an issue in the morning upon start up. But may happen again throughout the day. Any help would be great!
Do you
have the same problem?
Yes
No
Friday, August 4th, 2006 AT 12:23 PM

1 Reply

Tiny
TAURUSWHEEL
  • MEMBER
Ego sensor is the o2 sensor, it has zero effect on a dead-cold start, however with the built-in heaters, they start to output rather quickly. Shift solenoid doesn't have anything to do with it, have you scanned it lately. Like yesterday or today? These obdI systems are not like the newer, 95 and newer, obdII systems. You could have a part failing, but not enough to throw a code.
Was this
answer
helpful?
Yes
No
Friday, August 4th, 2006 AT 8:21 PM

Please login or register to post a reply.

Recommended Guides