2002 Dodge Ram Fuel system

Tiny
LAMM5
  • MEMBER
  • 2002 DODGE RAM
Engine Mechanical problem
2002 Dodge Ram V8 Four Wheel Drive 150000 miles

My truck surges from 2000 rpm to 2500 rpm while driving on the freeway or even when sitting park. The fuel pump has been replaced two times and the problem is still there
Do you
have the same problem?
Yes
No
Sunday, September 5th, 2010 AT 10:40 AM

11 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Have you checked the idle air control valve? Has the check engine light come on?
Was this
answer
helpful?
Yes
No
Sunday, September 5th, 2010 AT 11:38 PM
Tiny
LAMM5
  • MEMBER
No I have not checked the idle air control valve and no the engine light dont come on.
Was this
answer
helpful?
Yes
No
Monday, September 6th, 2010 AT 8:48 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Try disconnecting the IAC to see if the engine dies.

Let me know.
Was this
answer
helpful?
Yes
No
Monday, September 6th, 2010 AT 9:11 PM
Tiny
LAMM5
  • MEMBER
We have installed a new fuel pump, fuel filter, new coil pack, new spark plug wires and plugs. The car runs fine when cold. Once the engine is totally warmed up at normal running temp the engine quits quits and will not start until the motor cools down. What would cause this to happen
Was this
answer
helpful?
Yes
No
Sunday, September 26th, 2010 AT 12:13 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Are you getting spark when it doesn't start? Have you checked for fuel pressure when it doesn't start?
Was this
answer
helpful?
Yes
No
Monday, September 27th, 2010 AT 1:42 PM
Tiny
LAMM5
  • MEMBER
We have installed a new fuel pump, fuel filter, new coil pack, new spark plug wires and plugs. The car runs fine when cold. Once the engine is totally warmed up at normal running temp the engine quits quits and will not start until the motor cools down. What would cause this to happen?
Was this
answer
helpful?
Yes
No
Monday, September 27th, 2010 AT 2:56 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Please understand, without a check engine light and trouble code, it becomes a guessing game. My first guess is the crank sensor. Have you had that checked? Also, when it doesn't start warm, have you checked to see what is missing, fuel or spark?
Was this
answer
helpful?
Yes
No
Monday, September 27th, 2010 AT 9:06 PM
Tiny
LAMM5
  • MEMBER
Ok, so we tried all those new parts and the check engine lite has been on too. So we will get a price and try the sensor. Thanx
Was this
answer
helpful?
Yes
No
Tuesday, September 28th, 2010 AT 1:11 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Let me know what you find.

Joe
Was this
answer
helpful?
Yes
No
Friday, October 1st, 2010 AT 8:20 AM
Tiny
LAMM5
  • MEMBER
Ok I took your advice and took the car up to a machanic and he hooked it up to a machine to see what was wrong and sure enough. It was the crank sensor. So we replaced it yesterday an our daughter took it home last night and we have not gotten a call yet so we are assuming all is well. An just so you know. We replaced the TPS on the dodge ram and it is also running with no surging. So. Thank you sooooo much for all your help guys!
Was this
answer
helpful?
Yes
No
Friday, October 1st, 2010 AT 9:29 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Great! I'm glad it took care of the problem. Let us know if you have questions in the future, and I'm glad it helped you.

Take care,
Joe
Was this
answer
helpful?
Yes
No
Friday, October 1st, 2010 AT 12:42 PM

Please login or register to post a reply.

Recommended Guides