NO SPARK NO FUEL & LINK ERROR TO PCM

1998 Dodge Ram

Tiny

98_Dodge_Ram_Sport

June, 14, 2010 AT 12:15 AM

1998 Dodge Ram V8 Two Wheel Drive Automatic 115000 miles

OK, where do I start. My 98 dodge ram 1500 5.9L recently died on me. After attempting to jump start the truck the gauge lights started clicking and I could not start. It cranks fine and everything works as far as windows, wipers, lights and all accessories. I do NOT have spark to the plugs and the fuel pump does NOT turn on. I bypassed the fuel system relay and the pump does work and I get pressure to the rail but only after bypassing it. It does not prime when key goes to on position. Also, the check engine light comes on and shuts off like normal with PCM plugged in but also after I removed the PCM. I checked the ASD relay as well as all other relays and fuses. Everything checked out good. I replace the Crank Position Sensor however still nothing. I tried 2 different OBDII scanners and both gave me a link error. I have 12v getting to the PCM and grounds seem fine. The dodge dealership diagnosed the problem as a bad ground off the battery stating it had 200 ohms resistance. I have replaced that and still nothing. I have 12v to all the relays and fuses. What could this problem be? This has been going on for 3 weeks and is causing me to lose work days. Any help is greatly appreciated. Thank you, Dustin

FOUND 2774 RELATED QUESTIONS

14 Answers

Tiny

98_Dodge_Ram_Sport

June, 14, 2010 AT 10:10 PM

Anyone care to help me out? Thanks

Tiny

rasmataz

June, 17, 2010 AT 1:13 PM

Hi 98_Dodge_Ram_Sport, Welcome to 2carpros and TY for the donation and sorry for the delay

I want you to check for battery voltage on the coil and injectors dark green and orange wire and report back asap-we start here

Tiny

98_Dodge_Ram_Sport

June, 17, 2010 AT 1:16 PM

Do you want me to check with hey turned to ON position? Thanks

Tiny

rasmataz

June, 17, 2010 AT 1:21 PM

Yes sir

Tiny

98_Dodge_Ram_Sport

June, 17, 2010 AT 1:25 PM

Ill check now. Standby. Thanks

Tiny

98_Dodge_Ram_Sport

June, 17, 2010 AT 1:30 PM

I have no voltage at both injectors and coil.

Tiny

rasmataz

June, 17, 2010 AT 1:47 PM

Check fuse no.9 10amp in junction block right end of dash and fuse no. 6 30amp in the PDC if both okay and the ASD tested good-there's a problem with the computer ASD relay ground control circuit-

Tiny

98_Dodge_Ram_Sport

June, 17, 2010 AT 1:49 PM

As stated above, all fuses and relays were tested good. What is the ASD relay ground control circuit? Does that mean the PCM is bad?

Tiny

rasmataz

June, 17, 2010 AT 1:57 PM

Its gonna come to that-But do this jumper terminal 87 dark green and orange wire to terminal 30 with the red and light blue wire at the ASD relay socket this will direct power to the coil and injectors-let me know

Tiny

98_Dodge_Ram_Sport

June, 17, 2010 AT 2:09 PM

Ok, I jumped 87 to 30 and got 12 volts to the coil however still no spark. The fuel pump also did not prime. I bypassed the fuel pump relay for constant fuel however still nothing. There is plenty of pressure at the rail. What are you thinking at this point? Thanks

Please login or register to post a reply.

Ignition Coil System Test Repair - All Cars
Ignition System Test Guide
Crank Angle Sensor Replacement Mercedes Benz
Crankshaft Position Sensor Replace Chevrolet