2005 Dodge Neon Car starts to stall during accelaration

Tiny
BIKERGUYSOMD
  • MEMBER
  • 2005 DODGE NEON
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 78,000 MILES
I took the car out to a short drive, put gas in it from our local station, about 20 minutes later I felt a slight hesitation engine check light came on and while I tried to accelerate I had no power however gently touching the pedal I was able to proceed to cruising 55 and get the car home. Once home I checked all possible connections, thinking that a relay may have gotten stuck I disconnected the + battery terminal, jumped back in the car and started it without the check engine light on, took it around the block several times no issues. 1 day later I was headed out 20 minutes into the ride the same issue happened. I pulled over, took the + post off again turned it around and took it to my favorite parts place for a diagnostic test. The tech looked at the car with the computer however since I did not have a check engine light on he was not able to get a code. My wife is out this morning riding around trying to get the same issue to come up then take it to the parts place for a diag. I was wondering if anyone out there has had the same issue especially with taking the + post off the battery and clearing the issue for the moment. I am still thinking it may be a relay however others I have read states it could be the 02 sensor too.

thanks

Mike Davis
Do you
have the same problem?
Yes
No
Monday, July 7th, 2008 AT 7:29 AM

1 Reply

Tiny
JAEROCK3
  • MEMBER
Have you tried the ignition coil
Was this
answer
helpful?
Yes
No
Tuesday, July 15th, 2008 AT 4:43 PM

Please login or register to post a reply.

Recommended Guides