1994 Dodge Caravan STALL

Tiny
BROBERT
  • MEMBER
  • 1994 DODGE CARAVAN
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 100,000 MILES
My car stall after running for a while, we shut it down wait for a while restart the engine, run it againt, it shut down
Do you
have the same problem?
Yes
No
Tuesday, February 10th, 2009 AT 6:32 AM

3 Replies

Tiny
JDL
  • EXPERT
Hello, can you check for codes? Try cycling the key, on--off, on--off, on, you just turn the key till the dash lites come on, no crank. The check engine lite goes to flashing, you count the flashes to get the codes.

You could do some basic tests, if it refuses to start again, right away. Have a helper crank it, while you check for spark at the plugs and injector pulse.
Was this
answer
helpful?
Yes
No
Tuesday, February 10th, 2009 AT 8:38 AM
Tiny
95CAR-A-VAN
  • MEMBER
Hi brobert.
Yes, like [ jdl123 ] said, cycle the key and note the codes. Have paper and pen ready...
Did you read some of Thee Excellent infos @t:
http://www.2carpros.com/first_things/why_does_my_engine_die_stall_at_idle.htm

I'm having a similar problem:
1995 Caravan, V6, 3.3L, automatic, 225 000 KM = Last model-year of same generation as yours.
It starts but will not idle! Runs smooth when i give it gas, but will not idle! repeated self intentionaly
btw > I live in Montréal, Canada. Cold and/or wet winters!!
Here's what I've noticed in the last weeks:
Battery seemed to weakened (Slower turning starter), Radio-clock will not work (Fuse good).
Then today=
Tried to start Caravan. Cranked ok, fired-up, revs-up, but unable to idle. I had to reStart 3 times.
On the fourth try = Battery too weak to do it's job. I used the jumper pack to reStrat it 2 more times.
Reved-it-up for 1 minute to recharge both batteries. Still no idle = stalls!
Here's what I've done, and discovered:
Removed my battery to take it inside, inspect the liquid level and recharge-it. Yep! It's low on water.
And it has ONLY! 11.97 Volts. "it's DEAD Jim!". I topped it with neutral water and put the charger on.
(Last time i did that on previous car's batt., it did not bring my battery back to scale!) Still trying...
I'm suspecting that the too low VOLTage might have induce errors in ECM... I'm just guessing.
So I went back-out to the Van, and cycled the codes using the Power-Pack. Hey! The radio is ON!?!
But! Since I removed all power to the Computers for over 1 hour, codes are useless.
I only got 12, and 55 wich is END of diagnostic according to my Haynes Sunday Mechanic book.

Ok. Loooong post! Sorry...
I'll let the 1 amp charger do it's work overnight, take a measure, and see about this trouble tomorrow.
Maybe will have to go buy a New Battery... Hoping that will end this Stalling Trouble!!!...
N.B.:
And I will post here with latest news. Ciao Dude.
Was this
answer
helpful?
Yes
No
Tuesday, February 10th, 2009 AT 5:47 PM
Tiny
95CAR-A-VAN
  • MEMBER
Solution:=:=>
Replaced The Old, "it's Dead! Jim", Battery. Circa June 2006.

And now it's OK, xcept for the Radio-Clock that still won't come on!
Starts, idles and drives.

Did not have to replace any symptomatic sensors/valves :
Being;
, IAC= Idle Air Control Valve,
, MAP= Manifold Absolute Pressure,
, EGR= Exhaust Gas Recirculation
, Oxygen sensor, on Exhaust Manifold,

Darn CONmputers!
Electronics should have NEVER been Mixed with Mechanics!
I can understand it for emissions and performance, butt! Error intented = Cause it's a pain in thee!
But Pe-Leazzz! Make them better than Windows! I mean PLEASE! Come! On!

As for the radio-clock that will not come on, I'm now suspecting said accessory.
But who knows, , if it's still because of that Darn little silver box! = Dah CONpiouter.
Was this
answer
helpful?
Yes
No
Wednesday, February 25th, 2009 AT 7:49 PM

Please login or register to post a reply.

Recommended Guides