Dash gauges not working properly

Tiny
SHAWN STRUDWICK
  • MEMBER
  • 2004 CHEVROLET SILVERADO
  • 5.3L
  • V8
  • 2WD
  • AUTOMATIC
  • 265,000 MILES
Whenever the temperature gets hot the gauges will not move up and the brake lights come on. But as soon as the temperature cools down, everything works.
Do you
have the same problem?
Yes
No
Friday, October 4th, 2019 AT 4:53 PM

1 Reply

Tiny
JACOBANDNICKOLAS
  • EXPERT
Welcome to 2CarPros.

I have to be honest. I've seen many instrument clusters on these vehicles fail, but never have I seen the brake lights turn on. The only thing even tied to the cluster is the brake booster pump. With that, not all the trucks came with it and again, I don't see how that would be related.

So, we are going to try a couple things to see if we can narrow things down a bit. First, I need to know if any lights turn on at the cluster. Also, do the turn signals work properly when this happens?

Now, when this happens (brake lights on), I want you to disconnect the brake light switch at the top of the brake pedal to see if the lights go out. If they do, great. If they don't, then we have a short to power at a different location.

Next, when this happens, disconnect the brake booster pump if you have one. I attached a few pics below to help with locations. If we find neither of the aforementioned tests fail, then I suspect the cluster itself has malfunctioned or the body control module.

In the first picture, I highlighted and circled the circuit to the IP cluster that relates to the brake booster.

Let me know what you find.

Joe
Was this
answer
helpful?
Yes
No
Sunday, October 6th, 2019 AT 6:57 PM

Please login or register to post a reply.

Recommended Guides