2005 Chrysler Town and Country heater sporatic

Tiny
FIREBRIDE
  • MEMBER
  • 2005 CHRYSLER TOWN AND COUNTRY
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 108,000 MILES
For the last two winters my heater has been erratic. I can set the heater controls of both passenger and driver settings on 85 degrees in cold weather(0-60 degrees outside) and the same symptoms recur. I have dual front heat controls. The drivers side may blow hot for 3 minutes, while the passenger side blows cold. Then the passenger may heat up. Then they may both blow cold for 15 minutes. Then they may both blow hot for 5 minutes. Then they may both blow lukewarm air. Then both cold again. The van STAYS freezing at all times. What little heat it blows is not long enough to heat the van. I have gone through 3 coolant system thermostats and replaced the heat pump, and even have a new engine. Yet the SAME symptoms keep happening. Any ideas?
Do you
have the same problem?
Yes
No
Friday, December 18th, 2009 AT 4:34 PM

1 Reply

Tiny
JACOBANDNICKOLAS
  • EXPERT
Actually, I think you are looking for a vacuum leak. The vents are actuated by vacuum. If vacuum is weak, the heat amy not make it to the vehicle. Also, there is a blend door that will do the same thing. It's located near the heater core. Check under the dash for vacuum leaks as well as under the hood from the soruce. With the engine running, you may hear a hissing.

Let me know what you find.

Joe
Was this
answer
helpful?
Yes
No
Tuesday, December 22nd, 2009 AT 7:09 AM

Please login or register to post a reply.

Recommended Guides