NEW ECM computer

Tiny
TIBBSMICHAEL
  • MEMBER
  • 1998 CHRYSLER TOWN AND COUNTRY
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 187,000 MILES
I just installed new control computer. Now engine turns over but won't fire.
Do you
have the same problem?
Yes
No
Monday, January 12th, 2009 AT 4:07 PM

9 Replies

Tiny
JAMES W.
  • MEMBER
Is it not getting spark, or fuel, or both? Also, what prompted you to change the computer in the first place? Please advise.
Was this
answer
helpful?
Yes
No
Monday, January 12th, 2009 AT 5:47 PM
Tiny
TIBBSMICHAEL
  • MEMBER
It appears to be no fuel or spark. The new computer was installed after taking it to the dealership because all the electrics would just turn off no guages, speedometer, radio etc. They said a new computer would be needed to resolve
Was this
answer
helpful?
Yes
No
Monday, January 12th, 2009 AT 8:33 PM
Tiny
JAMES W.
  • MEMBER
If you are sure you're not getting spark or injector pulse, I would suspect the crankshaft position sensor. It's located in the bellhousing on the backside of the motor.
Was this
answer
helpful?
Yes
No
Monday, January 12th, 2009 AT 9:07 PM
Tiny
TYSFAMILY
  • MEMBER
I have the same problem on a 2003 Town Country 3.3 Flex, but I can change the PCM/ECM and it will start right up. It will run for 2 or 3 times, even drove it for 50 miles with out shutting it off, then just dead again. You can crank it and give it fuel and it will start for just a second or two then die. I put a 1999 PCU in and it runs great, never fails but no gages will work. You put the right one in again and 2 or 3 strarts later same thing, dead motor. Then it won't even try to turn over like the batterys disconnected. I can't keep replacing the PCM and I really need my van, please help.
Was this
answer
helpful?
Yes
No
Sunday, October 22nd, 2017 AT 6:10 AM
Tiny
KEN
  • ADMIN
This sounds like you have an auto shutdown relay that is having trouble. Here is a guide and some diagrams so you can do some checking. What happens is the contacts heat up and stop the connection when this relay wears out.

https://www.2carpros.com/articles/how-to-check-an-electrical-relay-and-wiring-control-circuit

Please let us know what happens.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Monday, October 23rd, 2017 AT 2:03 PM
Tiny
TYSFAMILY
  • MEMBER
Thanks, why is it that I can put the 1999 ECU in and it starts and drives.
Was this
answer
helpful?
Yes
No
Tuesday, October 24th, 2017 AT 12:30 PM
Tiny
KEN
  • ADMIN
When nothing happens not even crank over does the security light flash?
Was this
answer
helpful?
Yes
No
Wednesday, October 25th, 2017 AT 2:16 PM
Tiny
TYSFAMILY
  • MEMBER
The light is on all the time. I was told that most likely the wiring harness under the plenum is brittle and cracked then shorted out. Which crashes the ECU. The 99 ECU works because it's before the key chip security. I get error codes p0123, p0118 and p0508
Was this
answer
helpful?
Yes
No
Friday, October 27th, 2017 AT 6:10 PM
Tiny
KEN
  • ADMIN
That light needs to be off for the car to start. Do you have a spare key you can try? If you cant get the security light out the car will need to go to the dealer to be programmed.

This guide might help

https://www.2carpros.com/articles/how-to-reset-a-security-system

Please let us know what you find. I'm interested to see what it is.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Saturday, October 28th, 2017 AT 4:50 PM

Please login or register to post a reply.

Recommended Guides