1992 Chrysler Le Baron Fuel Pump is intermitant

Tiny
STEPCHILD
  • MEMBER
  • 1992 CHRYSLER LE BARON
Electrical problem
1992 Chrysler Le Baron 6 cyl Front Wheel Drive Automatic

for the past 3-4 weeks my '92 LeBaron has been giving me fits. When I turn the ignition key, I will normally hear the fuel pump prime. It now only works randomly. I have replaced the fuel pump relay and the pump itself (boy, that was fun), but still no joy. When I turn on the ignition and hear the pump, it will start. But, all too often, I don't get that beautiful hum that will allow me to go where I need to go. Any help?
Do you
have the same problem?
Yes
No
Wednesday, April 21st, 2010 AT 9:04 AM

10 Replies

Tiny
RASMATAZ
  • MEMBER
Start by testing the ignition switch and the ASD relay
Was this
answer
helpful?
Yes
No
-1
Thursday, April 22nd, 2010 AT 3:59 AM
Tiny
STEPCHILD
  • MEMBER
Thnx for the quick response.
Where would I find the shutdown relay? I can't seem to find it in any literature I have on the car. And, everything else functions normally when the key is in the start position, is there a direct link from the switch to the fuel system relay?

Side note: Thinking there may be a bad or corroded connection at the fuel relay, I sprayed a little WD-40 on the relay and the relay/fuse block, which helped, but did not fix it. I am going to remove the relay block and check for rusted or corroded connections.
Was this
answer
helpful?
Yes
No
Friday, April 23rd, 2010 AT 5:04 AM
Tiny
STEPCHILD
  • MEMBER
I checked the relay block and the ecu connections as well, all looks good. What are the chances that the Engine Control Unit itself is bad?

One more observation, it seems to start best in the morning and evening when it is cool. Springtime here in Va.
Was this
answer
helpful?
Yes
No
Friday, April 23rd, 2010 AT 10:55 AM
Tiny
RASMATAZ
  • MEMBER
The ASD relay is in the engine bay foward of left strut tower-see pic below-dunno about the computer yet-check basic stuffs before you go there.


http://www.2carpros.com/forum/automotive_pictures/12900_asd_5.jpg

Was this
answer
helpful?
Yes
No
+1
Friday, April 23rd, 2010 AT 5:01 PM
Tiny
STEPCHILD
  • MEMBER
Although the pic is not representative of my particular model, ('92 convertible) I did find the ASD relay and checked it with multimeter. Seems to be functioning fine. Any other suggestions? BTW I really do appreciate the help.
Was this
answer
helpful?
Yes
No
Tuesday, April 27th, 2010 AT 6:07 AM
Tiny
RASMATAZ
  • MEMBER
What kind of reading did you get from the ASD relay?
Was this
answer
helpful?
Yes
No
Tuesday, April 27th, 2010 AT 6:25 AM
Tiny
STEPCHILD
  • MEMBER
I don't know how they are numbered, but the pin that is flat compared to the others, had 0 volts in the off position and 13.8 with ignition on
Was this
answer
helpful?
Yes
No
Tuesday, April 27th, 2010 AT 1:21 PM
Tiny
RASMATAZ
  • MEMBER
Have the computer control of the ASD relay tested
Was this
answer
helpful?
Yes
No
Wednesday, April 28th, 2010 AT 1:38 PM
Tiny
STEPCHILD
  • MEMBER
Turns out the ECM has a physical crack. Replaced the module and all is well. I have my little red mid-life crisis back to par. Thanks for the help
Was this
answer
helpful?
Yes
No
Friday, May 7th, 2010 AT 12:38 PM
Tiny
2CARPROS LINSEY
  • MEMBER
Thank you for using 2CarPros. Com. We appreciate your donation and look forward to helping you in the future.
Was this
answer
helpful?
Yes
No
Friday, May 7th, 2010 AT 12:43 PM

Please login or register to post a reply.

Recommended Guides