Brake lights don't work

Tiny
SHELLYBELLYMATT
  • MEMBER
  • 2000 CHEVROLET VENTURE
Electrical problem 6 cyl All Wheel Drive Automatic 134000 miles

The upper brake light ( in the rear hatch) works, and the bulbs are all good. The running lights (same bulb as the stoplights) work, but no brake lights. Fuses are all good, bulbs are all good. What could this be? Since the hatch stoplght works, it can't be the switch under the pedal. What can I check next? I'm at a loss.
Do you
have the same problem?
Yes
No
Tuesday, March 3rd, 2009 AT 2:40 PM

2 Replies

Tiny
2CEXPT
  • MEMBER
Hello,

It sounds like a connection problem at both brake lights because if the center light works then the others should work as well because they are wired together. You may have a broken wire somewhere here is a guide to check for power and the brake light wiring diagrams so you can see how the system works.

https://www.2carpros.com/articles/how-to-use-a-test-light-circuit-tester

Check out the diagrams (Below)

Please let us know what you find. We are interested to see what it is.

Cheers
Was this
answer
helpful?
Yes
No
Tuesday, March 3rd, 2009 AT 3:00 PM
Tiny
SHELLYBELLYMATT
  • MEMBER
I found it! It was a broken wire in harness where it got rubbed through. Once I fixed it the problem is solved! Thanks for the brake light wiring diagram it really helped.

I love this site, all for free I cant believe it.
Was this
answer
helpful?
Yes
No
Thursday, March 5th, 2009 AT 3:10 PM

Please login or register to post a reply.

Sponsored links