2004 Chevy Trailblazer Rough idle only when cold

Tiny
MAHOY78SPYDER
  • MEMBER
  • 2004 CHEVROLET TRAILBLAZER
  • 6 CYL
  • 4WD
  • AUTOMATIC
  • 88,684 MILES
Hello... have 2004 Trailblazer EXT, 88K miles, no work done to motor other than oil changes. Engine idles very rough when cold, even stalls occasionally, but after a couple minute of driving (when warmed up) it runs just fine. Is this a sensor problem, and if so, which?


http://www.2carpros.com/forum/automotive_pictures/400662_114_2.jpg

Do you
have the same problem?
Yes
No
Monday, August 24th, 2009 AT 7:00 PM

3 Replies

Tiny
RASMATAZ
  • MEMBER
Test the resistances on the coolant temperature sensor hot and cold, also clean out the idle air control valve.

GM Coolant temperature sensor

Temp Resistances

-40 100.7
40 7.5
100 1.8
210 185
Was this
answer
helpful?
Yes
No
-1
Monday, August 24th, 2009 AT 7:15 PM
Tiny
MAHOY78SPYDER
  • MEMBER
Thanks for your blazingly quick response. I did a check on the IAC and learned that 2004 is the first year Chevrolet assembled it with the entire throttle body so it is no longer a separate component. I can see it visually on top there but don't see a way to clean it. Any suggestions?

Also, on the coolant temperature sensor. Where is it located exactly?
Was this
answer
helpful?
Yes
No
Wednesday, August 26th, 2009 AT 8:46 AM
Tiny
RASMATAZ
  • MEMBER
The coolant temperature sensor is located on left front of engine block near the alternator/generator as for the IACV you have to remove it form the TB and clean out-does yours looks like this


http://www.2carpros.com/forum/automotive_pictures/12900_IACV_2.jpg

Was this
answer
helpful?
Yes
No
+1
Wednesday, August 26th, 2009 AT 1:51 PM

Please login or register to post a reply.

Recommended Guides